Project

General

Profile

Actions

Bug #10656

open

Acme letsencrypt doesn't change private key type

Added by Howard Holm over 1 year ago. Updated over 1 year ago.

Status:
Feedback
Priority:
Normal
Category:
ACME
Target version:
-
Start date:
06/11/2020
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Affected Version:
Affected Plus Version:
Affected Architecture:

Description

As alluded to in this year and a half old post (https://forum.netgate.com/topic/116404/ntopng-and-let-s-encrypt-certificates) changing the private key configuration item from ECDSDA to RSA appears to succeed, but when re-issuing or renewing the key it silently continues to use the old private key type. At best this is very confusing when the configuration now shows one type of private key, but they system is actually receiving and using a previously configured type.

Actions #1

Updated by Viktor Gurov over 1 year ago

  • Status changed from New to Rejected

Duplicate of #10655

Please add any additional comments to that issue.

Actions #2

Updated by Howard Holm over 1 year ago

It isn't really a duplicate of that bug. The fallout of that bug sets up the conditions where you might want to change the key type, but the failure to change the type of the key is a completely separate issue. In fact, it looks like the related issue may be fixed with version 4.0 of ntopng. But that fix will have zero effect on this failure to change the key type in ACME.

Actions #3

Updated by Viktor Gurov over 1 year ago

  • Status changed from Rejected to Confirmed

Right, got the same issue

Actions #5

Updated by Jim Pingle over 1 year ago

  • Status changed from Confirmed to Pull Request Review
Actions #6

Updated by Renato Botelho over 1 year ago

  • Status changed from Pull Request Review to Feedback
  • Assignee set to Renato Botelho
  • % Done changed from 0 to 100
  • Affected Version deleted (2.4.5-p1)

PR has been merged. Thanks!

Actions

Also available in: Atom PDF