Project

General

Profile

Bug #10668

curl -T "{file1,file2}" loops forever eating up the RAM

Added by robi robi 4 months ago. Updated 23 days ago.

Status:
Resolved
Priority:
Normal
Category:
Operating System
Target version:
Start date:
06/17/2020
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.4.5-p1
Affected Architecture:

Description

Running pfSense 2.4.5-RELEASE-p1, using curl in ACME certificates Actions list to upload the updated certs from pfSense to machines down the internal network.

curl -T "{/tmp/acme/mydomain/mydomain.tld/ca.cer,/tmp/acme/mydomain/mydomain.tld/fullchain.cer,/tmp/acme/mydomain/mydomain.tld/mydomain.tld.cer,/tmp/acme/mydomain/mydomain.tld/mydomain.tld.csr,/tmp/acme/mydomain/mydomain.tld/mydomain.tld.key}" ftp://192.168.1.200 --user user:pass

This command runs after pfSense refreshed the certs. Currently with curl 7.67.0 (amd64-portbld-freebsd11.3) this causes an endless loop eating up the memory:

curl: (3) URL using bad/illegal format or missing URL
curl: (3) URL using bad/illegal format or missing URL
curl: (3) URL using bad/illegal format or missing URL
...

The bug was reported to curl dev team: https://github.com/curl/curl/issues/4588 they confirmed that his bug is in 7.67.0 for all builds and distros.

Please update the curl package separately for us.

History

#1 Updated by Jim Pingle 4 months ago

  • Category set to Operating System
  • Assignee set to Renato Botelho
  • Priority changed from High to Normal

#2 Updated by Renato Botelho 23 days ago

  • Status changed from New to Feedback
  • Target version set to 2.5.0

I've imported curl 7.68.0, which fixes this issue. Also bumped revision of ACME port to 0.68_3 and added a explicit curl dependency to make sure latest curl is installed.

2.5.0 already has a newer curl so it's not affected

#3 Updated by robi robi 23 days ago

After updating ACME package to the latest version, the system was updated with curl 7.68.0 (amd64-portbld-freebsd11.3) libcurl/7.68.0 OpenSSL/1.0.2u zlib/1.2.11 nghttp2/1.40.0
Release-Date: 2020-01-08

Now the problem is fixed:

  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  1647    0     0  100  1647      0  48441 --:--:-- --:--:-- --:--:-- 49909
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  3603    0     0  100  3603      0  3518k --:--:-- --:--:-- --:--:-- 3518k
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  1956    0     0  100  1956      0  1910k --:--:-- --:--:-- --:--:-- 1910k
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  1021    0     0  100  1021      0   997k --:--:-- --:--:-- --:--:--  997k
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  1679    0     0  100  1679      0  1639k --:--:-- --:--:-- --:--:-- 1639k

Thank you.

#4 Updated by Renato Botelho 23 days ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF