Project

General

Profile

Bug #10709

services_router_advertisements.php: radvd won't start if Default valid lifetime is less than Default preferred lifetime

Added by Mike Murdoch about 1 month ago. Updated about 1 month ago.

Status:
Feedback
Priority:
Normal
Category:
Web Interface
Target version:
Start date:
06/28/2020
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.4.5-p1
Affected Architecture:
All

Description

Hello,

the user interface allows the `Default valid lifetime` field to be set to a lower value than `Default preferred lifetime` field. When this is done, radvd will not start, due to

AdvValidLifeTime must be greater than AdvPreferredLifetime in /var/etc/radvd.conf, line 18

Someone less familiar with Pfsense will likely spend a lot of time trying to hunt why their IPv6 is nto working. The user interface should probably warn the user and not allow such a configuration to be saved in the first place (just like it is being done when the Default valid lifetime is set to below 7200)

Thanks!

Associated revisions

Revision 1d0608f3 (diff)
Added by Viktor Gurov about 1 month ago

RA lifetime input validation. Fixes #10709

History

#2 Updated by Jim Pingle about 1 month ago

  • Status changed from New to Pull Request Review
  • Target version set to 2.5.0

#3 Updated by Renato Botelho about 1 month ago

  • Status changed from Pull Request Review to Feedback
  • Assignee set to Renato Botelho
  • % Done changed from 0 to 100

PR has been merged. Thanks!

#4 Updated by Mike Murdoch about 1 month ago

That was super quick. Thanks a lot!

Also available in: Atom PDF