Project

General

Profile

Bug #10755

NAT rules not updating.

Added by Alhusein Zawi about 1 month ago. Updated about 1 month ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Rules / NAT
Target version:
-
Start date:
07/10/2020
Due date:
% Done:

0%

Estimated time:
Affected Version:
Affected Architecture:

Description

if I restore the configuration from old file , translation address (Outbound NAT rules) will be the wan address of old file and FW does not update it to use current wan address.

to work around : I need to go to each rule and press save.

Note: only NAT rule restored from backup configuration file.

History

#1 Updated by Jim Pingle about 1 month ago

  • Category set to Rules / NAT
  • Status changed from New to Rejected

I can't reproduce this. If the user had selected "<interface name> address" e.g. "WAN Address" in the rules, the config.xml entries do not contain the IP address but an internal identifier like wanip. There is no way that could have referenced a previous WAN address unless the user hardcoded the old address in the rule, in which case there is no way that the code could know it needed updated.

Look at a config history diff of when the correction was made, if the old IP address was in the old config, then the config was not using the "<interface> Address" macro entry before.

Also available in: Atom PDF