Project

General

Profile

Bug #11025

traffic shaper PHP error

Added by Niccolò Marchi 5 months ago. Updated 5 months ago.

Status:
Duplicate
Priority:
High
Assignee:
-
Category:
Traffic Shaper (ALTQ)
Target version:
Start date:
11/01/2020
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.5.0
Affected Architecture:
Release Notes:
Default

Description

amd64
12.2-STABLE
FreeBSD 12.2-STABLE 2841d41b090(devel-12) pfSense

Crash report details:

PHP Errors:
[01-Nov-2020 12:45:10 Europe/Rome] PHP Fatal error: Uncaught Error: Call to a member function GetScheduler() on null in /etc/inc/shaper.inc:1581
Stack trace:
#0 /etc/inc/shaper.inc(2283): priq_queue->validate_input(Array, NULL)
#1 /etc/inc/shaper.inc(902): hfsc_queue->validate_input(Array, NULL)
#2 /usr/local/www/wizards/traffic_shaper_wizard_multi_all.inc(876): altq_root_queue->add_queue(Object(hfsc_queue), Array, Array, NULL)
#3 /usr/local/www/wizards/traffic_shaper_wizard_multi_all.inc(697): apply_all_chosen_items()
#4 /usr/local/www/wizard.php(116) : eval()'d code(1): step8_stepsubmitphpaction()
#5 /usr/local/www/wizard.php(116): eval()
#6 {main}
thrown in /etc/inc/shaper.inc on line 1581

History

#1 Updated by Jim Pingle 5 months ago

  • Target version set to 2.5.0

#2 Updated by Jim Pingle 5 months ago

  • Affected Version set to 2.5.0

#3 Updated by Viktor Gurov 5 months ago

  • Status changed from New to Duplicate

Duplicate of #10998#note-5

Also available in: Atom PDF