Project

General

Profile

Bug #11159

Allow wildcard dns record of type A in the DynDNS client for DNS provider Gandi

Added by Sébastien Trupel 3 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Category:
Dynamic DNS
Target version:
Start date:
12/13/2020
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.4.5-p1
Affected Architecture:
All

Description

Configuring a Dynamic DNS Client for the DNS provider Gandi with a wildcard address record (e.g. "*.example.com", which is a valid DNS record of type A) does not validate the web form, error message : The hostname contains invalid characters.
The DNS provider Gandi supports that type of DNS record.
This problem is similar to the issue #9053.

The expected behavior is that a hostname with a wildcard character would be allowed, given that it's a perfectly valid DNS record for the DNS provider Gandi.

Additionnally, since the DNS provider Gandi was made available on pfSense (#9452), Gandi is currently transitionning to a new REST API and the former REST API (used in the commit edfe22f https://github.com/pfsense/pfsense/pull/4061/commits) will not be developed anymore according to this documentation : https://doc.livedns.gandi.net/ There will be no future developments on this API, as we are merging to our new REST api endpoint.
Changing the URL and the syntax of the authorization header could permit to query the new API, according to this documentation : https://api.gandi.net/docs/livedns/#v5-livedns-domains-fqdn-records.

The affected files are :
  • src/etc/dyndns.class
  • src/usr/local/www/services_dyndns_edit.php

I will create a Pull Request on GitHub to that effect.

Associated revisions

Revision cb8ecda5 (diff)
Added by Sébastien Trupel 3 months ago

Allow wildcard DNS record of type A in DynDNS client for DNS provider Gandi. Ticket #11159.

History

#2 Updated by Jim Pingle 3 months ago

  • Status changed from New to Pull Request Review

#3 Updated by Renato Botelho 2 months ago

  • Status changed from Pull Request Review to Feedback
  • Assignee set to Renato Botelho
  • Target version set to 2.5.0

PR has been merged. Thanks!

#4 Updated by Renato Botelho about 1 month ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF