Project

General

Profile

Actions

Bug #11174

open

Incorrect traffic shaping on pppoe interface

Added by Alexey Ab 7 months ago. Updated 7 months ago.

Status:
Feedback
Priority:
Normal
Assignee:
-
Category:
Traffic Shaper (ALTQ)
Target version:
-
Start date:
12/19/2020
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.4.5-p1
Affected Architecture:
amd64

Description

I am trying to set up shaping on pppoe WAN interface. Tried both 2.4.4-RELEASE-p1 and 2.4.5-RELEASE-p1 using VMWare Workstation 15.5.

For example, on 100 mbit pppoe WAN I am trying to apply 50 MBit limit:

altq on pppoe0 fairq qlimit 1000 bandwidth 50Mb queue { test }
queue test on pppoe0 bandwidth 50Mb priority 1 qlimit 1000 fairq ( default )

Which ends up WAN interface showing 50 Mbit during upload, LAN shows 25 Mbit, and actual data stream on receiver is 25 Mbit.
I have found similar bug report https://redmine.pfsense.org/issues/8463 , but it was resolved by changing adapter to em.
I am already using em, and tried to change it to vmxnet3, but issue is still present.

I've also tried to disable vm.pmap.pti=0, but no success.

When I try the same shaping on non-pppoe interface then it works normally.

Attaching the file showing discrepancy between wan and lan speed during test upload (to server with 160 ms RTT).


Files

pppoe-shaping.png (24 KB) pppoe-shaping.png wan speed is 2x lan speed when shaping enabled Alexey Ab, 12/19/2020 12:59 AM
PFSense-FairQ-Problem.zip (88.7 KB) PFSense-FairQ-Problem.zip Alexey Ab, 12/21/2020 11:18 PM
Actions #1

Updated by Jim Pingle 7 months ago

  • Status changed from New to Feedback

Test again on a 2.5.0 snapshot, though it's likely a config or environment issue and not a bug in pfSense

Actions #2

Updated by Alexey Ab 7 months ago

Tested upload of 1Gb file to 165 ms RTT server via SFTP on:

2.4.2: Traffic shaping working as expected, bandwidth displayed incorrectly
2.4.5-p1: Traffic shaping gives too low and unstable bandwidth, bandwidth displayed incorrectly
2.5: Traffic shaping not working at all in two variants:
1) There is no limit for speed (and no queues present in status)
2) Thraffic is blocked until i remove shaper or restart pppoe (and no queues present in status)

I've used the same config file for all versions. Attaching archive with screenshots, vmx config file for VMWare, and config for PFSense.

Actions

Also available in: Atom PDF