Project

General

Profile

Bug #11291

WireGuard MTU Can Flap between 1420 and 1500

Added by Christian McDonald 3 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
WireGuard
Target version:
Start date:
01/22/2021
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.5.x
Affected Architecture:
Release Notes:
Default

Description

The default WireGuard MTU is typically 1420. However , I’ve observed cases where the wg interfaces will flap between 1500 and 1420. Explicitly configuring an MTU on the interface configuration fixes it

Associated revisions

Revision 8b9d2275 (diff)
Added by Jim Pingle 3 months ago

Use correct default MTU for WireGuard. Fixes #11291

History

#1 Updated by Christian McDonald 3 months ago

I've nailed down clear reproduction steps...assuming that you have a WG tunnel and it's corresponding wg interface assigned.

  1. Go to the WG interface configuration and click save and apply.
  2. Check Status > Interfaces and the WG interface will have an MTU of 1500
  3. Go to the VPN > Wireguard > Tunnel configuration and click save
  4. Check Status > Interfaces again and the WG interface will now have an MTU of 1420

This is obviously problematic and was discovered by OSPF adjacency issues because the remote end had a fixed MTU of 1420, which is the WG default. I've disable MTU mismatch detection on both ends for the time being.

#2 Updated by Jim Pingle 3 months ago

  • Status changed from New to In Progress
  • Assignee set to Jim Pingle

#3 Updated by Jim Pingle 3 months ago

  • Status changed from In Progress to Feedback
  • % Done changed from 0 to 100

#4 Updated by Christian McDonald 3 months ago

Looks good, thanks for the quick update

#5 Updated by Jim Pingle 3 months ago

  • Status changed from Feedback to Resolved

MTU is stable on current snapshots. It's 1420 even after save/apply on an assigned interface.

Also available in: Atom PDF