Project

General

Profile

Actions

Bug #11370

closed

firewall_aliases_edit.php is limited in the number of input entries it can save to an alias

Added by Marcos Mendoza 6 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Aliases / Tables
Target version:
-
Start date:
02/04/2021
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Default
Affected Version:
All
Affected Architecture:

Description

This is likely related to #10937

When creating a new alias of type "host", the number of entries that get saved is limited to a relatively small number.

Steps to reproduce:

- Under "Firewall / Aliases", import a list containing 520 lines of IP addresses
- Apply changes
- Under "Diagnostics / Tables", select the test alias
- The number of records shown is less than what was imported
- This can also be seen with the command: pfctl -t test_alias -T show | wc -l

Switching the alias type to "Network", saving, then applying, leads to a table with 0 entries.


Files

table_records.png (53.4 KB) table_records.png Marcos Mendoza, 02/04/2021 12:07 PM
command_output.png (25.3 KB) command_output.png Marcos Mendoza, 02/04/2021 12:07 PM
alias_input_field_count.png (50.4 KB) alias_input_field_count.png Marcos Mendoza, 02/04/2021 12:07 PM
big500.txt (8.03 KB) big500.txt 600+ test list Viktor Gurov, 05/14/2021 03:36 AM
Actions #1

Updated by Viktor Gurov 3 months ago

unable to reproduce it on 2.6.0.a.20210513.0100 - I can successfully import a list containing 600+ lines and see all records on the "Firewall / Aliases" and "Diagnostics / Tables" pages.

Actions #2

Updated by Marcos Mendoza 2 months ago

  • Status changed from New to Closed

This was originally tested with 2.4.5p1 and 2.5.0 iirc.

I can no longer reproduce this on 21.02.2, 21.05-RC, nor 2.5.1. Tested with 1353 entries. Closing this ticket.

Actions

Also available in: Atom PDF