Project

General

Profile

Bug #11372

I can delete nested alias even if it is in use

Added by Alexey Muzychenko 2 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Aliases / Tables
Target version:
Start date:
02/05/2021
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.5.0
Affected Architecture:
Release Notes:
Default

Description

If I define an alias, use it in any firewall rule directly and try to delete the alias - I get an error "Cannot delete alias. Currently in use by ."
But if I define other alias and use it inside other alias, I can delete it without any checking, even if it is in use.

In such case "IP" nested alias can be deleted without any error prompts, but if I delete nested "Ports" alias, after applying setting it leads to the error in the Notices: "Empty destination port alias 'name_of_alias' for rule ''"

Tested on
2.5.0-DEVELOPMENT (amd64)
built on Mon Feb 01 00:03:10 EST 2021
FreeBSD 12.2-STABLE

Associated revisions

Revision 65371889 (diff)
Added by Viktor Gurov 2 months ago

Nested alias checking fix. Issue #11372

Revision d6b55b5f (diff)
Added by Viktor Gurov 2 months ago

Nested alias checking fix. Issue #11372

History

#1 Updated by Michael Spears 2 months ago

Alexey Muzychenko wrote:

If I define an alias, use it in any firewall rule directly and try to delete the alias - I get an error "Cannot delete alias. Currently in use by ."
But if I define other alias and use it inside other alias, I can delete it without any checking, even if it is in use.

In such case "IP" nested alias can be deleted without any error prompts, but if I delete nested "Ports" alias, after applying setting it leads to the error in the Notices: "Empty destination port alias 'name_of_alias' for rule ''"

Tested on
2.5.0-DEVELOPMENT (amd64)
built on Mon Feb 01 00:03:10 EST 2021
FreeBSD 12.2-STABLE

I was unable to reproduce this on two different testing firewalls. Please provide additional information to reproduce.

#3 Updated by Jim Pingle 2 months ago

  • Status changed from New to Pull Request Review

#4 Updated by Renato Botelho 2 months ago

  • Status changed from Pull Request Review to Feedback
  • Assignee set to Viktor Gurov
  • Target version set to 2.5.0

Merged

#5 Updated by Jim Pingle 2 months ago

  • Status changed from Feedback to Closed

This is working fine. On current code I can't delete an alias which is nested in another in-use alias.

Also available in: Atom PDF