Project

General

Profile

Actions

Bug #11424

closed

Toggling pfSense update branch can lead to deinstall of packages without user confirmation

Added by M Felden 7 months ago. Updated 7 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Package System
Target version:
-
Start date:
02/15/2021
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.4.5-p1
Affected Architecture:
amd64

Description

2.4.5_1

Expected Behavior:

Merely changing update branch in System -> Update -> Update settings to RC should not modify the system.

Actual behavior:

Some packages are deinstall in the background without user instruction or confirmation.

Steps to reproduce:

1) Have a bunch of packages installed, among them is FRR. FRR is BGP announcing some IPv6 prefix.

2) Go to System -> Update -> Update settings. Change branch from stable to RC. Hit Save. - see attached pfs2.PNG. Return to dashboard.

3) View list of installed packages. All packages are present. Some show updates available due to newer branch. - see attached pfs1.PNG

4) Do nothing to packages. Base system is still 2.4.5-p1. Do not update system or packages. Return to dashboard.

5) Decide not to do anything with RC, go back to System -> Update -> Update settings and set branch back to 2.4.x stable - see attached pfs3.PNG.

6) Notice FRR no longer announcing the prefix. Go back to package manager and view list of packages. FRR and some others have been unilaterally deinstalled. See attached pfs4.PNG


Files

pfs3.PNG (102 KB) pfs3.PNG View of system -> Update showing branch toggled back to 2.4.x stable M Felden, 02/15/2021 09:20 PM
pfs4.PNG (211 KB) pfs4.PNG View of installed packages list after toggling back. Note that FRR was deinstalled M Felden, 02/15/2021 09:20 PM
pfs2.PNG (111 KB) pfs2.PNG View of system -> Update showing current rev and branch set to 2.5.0-RC M Felden, 02/15/2021 09:20 PM
pfs1.PNG (211 KB) pfs1.PNG List of packages when branch is set to 2.5.0-RC M Felden, 02/15/2021 09:20 PM
Actions #1

Updated by Jim Pingle 7 months ago

  • Status changed from New to Duplicate

Same root issue as #10464

Some of that can't be avoided due to conflict prevention, but solving the existing issue will likely also solve this. Can be revisited if it does not.

Actions #2

Updated by M Felden 7 months ago

I just want to clarify: In the case here the user does nothing to trigger a package update.

Merely toggling the branch without attempting any install or upgrade of anything causes packages to deinstall.

Actions #3

Updated by Jim Pingle 7 months ago

In the upgrade case, the branch is switched automatically. In your case, you did it manually. Same root cause.

Actions

Also available in: Atom PDF