Project

General

Profile

Bug #11543

SquidGuard 1.16.18_15 - returning wrong page

Added by Robson Ferreira about 2 months ago. Updated about 1 month ago.

Status:
Duplicate
Priority:
Normal
Category:
squidguard
Target version:
-
Start date:
02/25/2021
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.5.0
Affected Architecture:

Description

I have configurate squid+ squidguard, with autentication ldap, after Renato fixed problem with ldap filter.
So another problem is when Im using squidguard recentely installed. with anything more just default rule, so because this I have all site blocked, its ok, but when I access http site is ok, page is show nice but when I try access htts site with ssl interceptation, the page anexed is showed.

The page that is showed is not right, if i use only squid without squidguard, page is ok, with right page error.

page http blocked is ok.png (23.6 KB) page http blocked is ok.png Robson Ferreira, 02/25/2021 05:11 PM
page https with error.png (54.2 KB) page https with error.png Robson Ferreira, 02/25/2021 05:11 PM
page with only squid https.png (67 KB) page with only squid https.png Robson Ferreira, 02/25/2021 05:11 PM

History

#1 Updated by Jim Pingle about 2 months ago

  • Target version deleted (2.5.1)

#2 Updated by Viktor Gurov about 1 month ago

I can reproduce this issue in SSL/MITM Mode = "Splice Whitelist, Bump Otherwise"
in "Splice All" mode returns the correct redirect page

#3 Updated by Viktor Gurov about 1 month ago

  • Status changed from New to Duplicate

duplicate of #8827

Also available in: Atom PDF