Project

General

Profile

Regression #11568

Alias name change is not reflected in firewall rules

Added by Vendel Cseh 3 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Aliases / Tables
Target version:
Start date:
02/27/2021
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Default
Affected Version:
2.5.0
Affected Architecture:

Description

To reproduce the issue:

- Create an alias ( ip or port )
- Make a firewall rule containing the alias ( source or destination )
- Apply the rule and verify it is displayed as an alias in the rule table (hover over alias name)
- Edit the alias and rename it
- Go back to the firewall rules page. Verify that the new alias name appears and that the correct alias targets are displayed when hovering over the name.

History

#1 Updated by Jim Pingle 3 months ago

  • Subject changed from Alias rename not updating firewall rules ( causing Unresolvable destination alias error ) to Alias name change is not reflected in firewall rules
  • Status changed from New to Resolved
  • Assignee set to Steve Beaver
  • Target version set to CE-Next
  • Affected Version set to 2.5.0

Already fixed in NG 5685 and 6ecf793e0f4a5c3922c5c00a087a1adea104e50a (master) 585e7567d0e308ce440ff1b0651976c97fe58115 (RELENG_2_5_0).

Closing this since the other entry is on our internal Redmine

#2 Updated by Jim Pingle 3 months ago

  • Tracker changed from Bug to Regression

#3 Updated by Jim Pingle 2 months ago

  • Target version changed from CE-Next to 2.5.1

#4 Updated by Jim Pingle 2 months ago

  • Status changed from Resolved to Feedback

Needs re-tested on snapshots.

#5 Updated by Steve Beaver 2 months ago

  • Description updated (diff)

#6 Updated by Alhusein Zawi 2 months ago

  • Status changed from Feedback to Resolved

new alias name appears after changing the name.
targets are displayed

tested on IP & IP aliases.

2.5.1-RC (amd64)
built on Thu Mar 11 09:11:02 EST 2021

Also available in: Atom PDF