Project

General

Profile

Actions

Bug #11696

closed

SquidGuard Disable "Groups ACL" no work

Added by Viktor Gurov 10 months ago. Updated 21 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
squidguard
Target version:
-
Start date:
03/18/2021
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Affected Version:
Affected Plus Version:
Affected Architecture:

Description

https://forum.netgate.com/topic/162053/squidguard-disable-groups-acl-no-work-bug:
Pfsense 2.5.0

"Common ACL" is DENY ALL

I have SquidGuard with 10 Groups Acl. When disable the firts ACL, SquidGuard disable ALL ACL. But The navigation is totally 100% free without restrictions .

When disable the sixth ACL, Squidguard disables 7,8,9 and 10 ACL. But The navigation is totally 100% free without restrictions.

Actions #2

Updated by Jim Pingle 10 months ago

  • Status changed from New to Pull Request Review
Actions #3

Updated by Viktor Gurov 10 months ago

  • Status changed from Pull Request Review to Feedback

Merged

Actions #4

Updated by Azamat Khakimyanov 21 days ago

  • Status changed from Feedback to Resolved

Tested on 21.05.2

I've created 10 different Group ACLs for 3 VM PCs I had (Ubuntu, Windows10 and Xubuntu).
After creating these Group ACLs I tested them and all of them worked correctly and blocked/allowed web access according to different Target Categories I made.

After I disabled first Group ACL I created for Ubuntu, Ubuntu PC lost connection completely because Common ACLs were Deny ALL. But all other Group ACLs continued to work correctly: Windows10 and Xubuntu had access or were blocked according to Group ACLs (Target Categories) which were created for them.

So then I disable 6th ACL, Xubuntu still had access/were blocked according to its Group ACL. Traffic from Xubuntu were regulated by 10th Group ACL.

I'll mark this Bug as resolved

Actions

Also available in: Atom PDF