Project

General

Profile

Actions

Todo #12060

closed

Remove deprecated ``libzmq`` code and references

Added by Jim Pingle 4 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Category:
Build / Release
Target version:
Start date:
06/18/2021
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
21.09
Release Notes:
Default

Description

Once upon a time ZMQ was intended to be a potential logging or notification type, but that hasn't been touched in quite some time.

We still include libraries and modules for it, and a couple lines of code, all of which can be removed since they are not needed.

etc/inc/syslog.inc:        if (isset($syslogcfg['zmqserver'])) {
etc/inc/syslog.inc:*.*                                ^{$syslogcfg['zmqserver']}
etc/rc.php_ini_setup:PHPMODULES="$PHPMODULES zmq" 

The following libraries and dependencies can be removed after the other references to zmq are removed:

libzmq4-4.3.4
php74-pecl-zmq-1.1.3_3
Actions #1

Updated by Renato Botelho 4 months ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100
Actions #2

Updated by Renato Botelho 4 months ago

  • Assignee set to Renato Botelho
Actions #3

Updated by Jim Pingle 2 months ago

  • Subject changed from Remove deprecated libzmq pieces to Remove deprecated ``libzmq`` code and references

Updating subject for release notes.

Actions #4

Updated by Jim Pingle about 2 months ago

  • Status changed from Feedback to Resolved

All traces are gone as far as I can see.

Actions

Also available in: Atom PDF