Project

General

Profile

Actions

Bug #12078

closed

DNS Resolution Behavior does not consider named when setting localhost

Added by Marcos Mendoza about 1 month ago. Updated 30 days ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
Web Interface
Target version:
-
Start date:
06/24/2021
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Default
Affected Version:
Affected Architecture:

Description

With dnsmasq and unbound disabled, and instead using Bind/named, the setting DNS Resolution Behavior under System / General Setup does not add 127.0.0.1 to /etc/resolv.conf.

It does not appear to cause any issues, as dns lookups seem to default to using localhost (e.g. update checks and DNS Lookup page still work). Given, it's unclear why there are checks for these processes, rather than explicitly setting localhost unless Use remote DNS Servers, ignore local DNS is used.

Additionally, should ::1 for IPv6-only scenarios be taken into account?

Actions #1

Updated by Jim Pingle 30 days ago

  • Status changed from New to Not a Bug

Since named is a package, it doesn't integrate into base in that way by design. If someone wants to set that up and use it in that way, they need to manually configure things and not use features which are built around the base system components.

Actions

Also available in: Atom PDF