Project

General

Profile

Actions

Todo #12235

closed

``pfSense-upgrade`` should reinstall all packages on new version upgrades

Added by Renato Botelho 2 months ago. Updated 21 days ago.

Status:
Resolved
Priority:
Normal
Category:
Upgrade
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
21.09
Release Notes:
Default

Description

Today pfSense rely only on pkg to detect what must or not be upgraded. Sometimes a package is rebuilt using the same version when a new pfSense version comes and it's not reinstalled during release upgrade and ended up being different from what is present on a fresh install.

In order to improve this situation and make sure all packages are the same if we upgrade or do a fresh install, implement a mechanism that forces all packages reinstallation when the value of /etc/version changes.

This way full reinstall will never happen while using a -DEVELOPMENT snapshot but will for sure happen when it moves to -ALPHA, -BETA, -RC or -RELEASE. Also will happen when upgrading from X.Y-RELEASE to W.Z-RELEASE.

Actions #1

Updated by Renato Botelho 2 months ago

  • Status changed from New to Feedback

Implemented on pfSense-upgrade 1.0_2

Actions #2

Updated by Jim Pingle about 2 months ago

  • Subject changed from pfSense-upgrade: Reinstall all packages on new version upgrades to ``pfSense-upgrade`` should reinstall all packages on new version upgrades

Updating subject for release notes.

Actions #3

Updated by Renato Botelho about 2 months ago

  • Status changed from Feedback to In Progress

I found a bug on current implementation because control file is installed by pfSense-upgrade and it is not rebuilt when we change version

Actions #4

Updated by Renato Botelho about 2 months ago

  • Status changed from In Progress to Feedback

Fixed moving control file to be installed by pfSense-repo package

Actions #5

Updated by Renato Botelho 22 days ago

  • Status changed from Feedback to In Progress

There were some reports of crash logs showing up after upgrade and also PHP complaining about libpfctl missing during upgrade. Those errors were caused by this change and I'm finishing test a fix

Actions #6

Updated by Renato Botelho 22 days ago

  • Status changed from In Progress to Feedback

Fixed by pfSense-upgrade 1.0_6

Actions #7

Updated by Renato Botelho 21 days ago

  • Status changed from Feedback to Resolved

Fixed now

Actions

Also available in: Atom PDF