Project

General

Profile

Actions

Bug #12247

closed

Viewing an AutoConfigBackup entry takes approximately 60 seconds to completely load

Added by Steve Beaver 2 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Backup / Restore
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
21.09
Release Notes:
Default
Affected Version:
Affected Architecture:

Description

Build: 21.09.a.20210811.0100 - When viewing an ACB backup, the encrypted and decrypted versions of the backup should be displayed in separate text areas. The display is currently very slow and incomplete. This appears to be due to the length of the displayed data.

Actions #1

Updated by Steve Beaver 2 months ago

  • Assignee changed from Steve Beaver to Renato Botelho

If I attempt to view a backup by clicking on the "view" icon, I should see both the encrypted and decoded config on the screen. What is happening is that 1) It takes about 60 seconds to display and 2) the display is not complete.

If I edit crypt.inc and make the crypt_data() function return a formatted string

$result = "---- BEGIN config.xml ----\nSomeDecryptionKey++++pfsense Decoded data\n---- END config.xml";
the same thing happens. It displays my formatted string, but it still takes 60 seconds.

If I comment out the exec(openssl . . . line in that function, everything works normally and I see my formatted string immediately.

openssl writes the decrypted data to a file and I see that file (and its correct contents) immediately. So it seems like something that exec(openssl . . is doing is breaking PHP but what?

Actions #2

Updated by Steve Beaver 2 months ago

  • Description updated (diff)
Actions #3

Updated by Steve Beaver 2 months ago

Issue was caused by a missing curl_close() call, making the system wait until the acb server timed out.

Actions #4

Updated by Steve Beaver 2 months ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100
Actions #5

Updated by Steve Beaver 2 months ago

  • Assignee changed from Renato Botelho to Steve Wheeler
Actions #6

Updated by Steve Wheeler 2 months ago

  • Status changed from Feedback to Resolved

This looks good.

The files open quickly and completely. Both encrypted and decrypted parts.

Tested:

21.09-DEVELOPMENT (amd64)
built on Wed Aug 18 01:12:01 EDT 2021
FreeBSD 12.2-STABLE

and
2.6.0-DEVELOPMENT (amd64)
built on Wed Aug 18 01:08:59 EDT 2021
FreeBSD 12.2-STABLE

Actions #7

Updated by Jim Pingle 2 months ago

  • Target version changed from CE-Next to 2.6.0
  • Plus Target Version changed from Plus-Next to 21.09
Actions #8

Updated by Jim Pingle about 2 months ago

  • Subject changed from Viewing an ACB backup is slow and incomplete to Viewing an AutoConfigBackup entry takes approximately 60 seconds to completely load
  • Category changed from Web Interface to Backup / Restore
  • Assignee changed from Steve Wheeler to Steve Beaver

Updating subject for release notes.

Actions

Also available in: Atom PDF