Project

General

Profile

Bug #1230

Switching pfSense to HTTP from HTTPS Doesn't Free Up Certificate

Added by Steve Vigneau over 9 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Web Interface
Target version:
-
Start date:
01/26/2011
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

When pfSense is switched from HTTPS to HTTP the certificate that had previously been selected for HTTPS is still listed as in use and thus it cannot be deleted. To delete said cert a new cert needs to be created, then in Advanced select the HTTPS radio button, pick the alternate cert, set the radio button back to HTTP to hide the cert selection, and click save. The alternate cert will then be marked as in use.

I think this makes it impossible to select no cert for HTTPS which makes redoing all certificates on a pfSense box difficult.

History

#1 Updated by Jim Pingle over 9 years ago

  • Status changed from New to Closed

Duplicate of #1171

Also available in: Atom PDF