Project

General

Profile

Bug #1231

Upgrading pfSense Removed Internal CA

Added by Steve Vigneau over 8 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Package System
Target version:
Start date:
01/26/2011
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.0
Affected Architecture:
All

Description

Updated from a version of pfSense from early today to the latest version (2.0-BETA5 (i386) built on Wed Jan 26 10:45:46 EST 2011) and my CA tab is now blank with the internal CA missing. All certificates are now listed as External issuer where they had previously listed the internal CA.

Restoring from a backup config taken just before the upgrade put the internal CA back and things are once again working as expected.

Associated revisions

Revision fc05822b (diff)
Added by Jim Pingle over 8 years ago

Don't pass these by reference. Might be related to ticket #1231

Revision 5289dc57 (diff)
Added by Jim Pingle over 8 years ago

Do not use references here when building a ca_chain_array. Really fixes #1231 - CAs are no longer lost when a config write happens at bootup.

History

#1 Updated by Jim Pingle over 8 years ago

  • Category changed from Upgrade to Package System
  • Target version set to 2.0
  • Affected Architecture set to All

We've been trying to track that down for a bit.

See this thread:
http://forum.pfsense.org/index.php/topic,32372.0.html

Seems to be related to package removal, though it still isn't clear how or why it only affects certain people/configurations. Follow along the thread and post info there.

#2 Updated by Jim Pingle over 8 years ago

  • Status changed from New to Feedback

There have been a couple positive reports that some commits I made last week may have solved this. I'll leave it in 'feedback' state for a while to see if more reports surface one way or the other.

#3 Updated by Jim Pingle over 8 years ago

  • % Done changed from 0 to 100

#4 Updated by Jim Pingle over 8 years ago

  • Status changed from Feedback to Resolved

Several people on the forum who could reproduce this before are no longer losing their CA. Looks like it's fixed.

Also available in: Atom PDF