Project

General

Profile

Actions

Bug #12365

closed

PFBlockerNG - Unbound fails to start 3.1.0

Added by D B about 1 month ago. Updated 16 days ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
pfBlockerNG
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Affected Version:
2.5.2
Affected Plus Version:
Affected Architecture:
amd64

Description

Hi;

Unbound fails to start after reloading pfBlockerNG. Seems to have only started with PfBlockerNG - 3.1.0

I have tried both unbound/python modes

Python Mode:

Starting Unbound Resolver... Not completed. [ 09/11/21 11:27:41 ]
error: SSL handshake failed

Unbound Mode:
Assembling DNSBL database...... completed [ 09/11/21 11:43:06 ]
Stopping Unbound Resolver.
Unbound stopped in 2 sec.
Additional mounts:
No changes required.
Starting Unbound Resolver... Not completed. [ 09/11/21 11:43:43 ]

It then cycles through the IPs with seemingly no problems

Disabling PfBlockerNG allows Unbound to start and DNS to be resolved.

System Log just shows the service stopping and that's it

Please let me know if I can give any more info - I'm certainly no expert

Actions #1

Updated by D B 25 days ago

php-fpm 52285 /status_services.php: The command '/usr/local/sbin/unbound -c /var/unbound/unbound.conf' returned exit code '1', the output was '[1632742672] unbound[62823:0] error: bind: address already in use [1632742672] unbound[62823:0] fatal error: could not open ports'

Actions #2

Updated by Kris Phillips 20 days ago

  • Status changed from New to Feedback

Completed the following tests:

1. Installed pfBlockerNG-dev
2. Ran a force update and reload
3. Monitored logging

I wasn't able to reproduce this problem.

Based on the error message you have it would seem that something is already bound to unbound's ports. Do you possibly have the DNS Forwarder enabled or another DNS package for pfSense? I would recommend trying to reboot to see if your problem goes away because this seems unique to your firewall install and not representative of pfSense as a whole.

If you do believe this is a bug please reply after testing again post-reboot and provide additional logging.

Actions #3

Updated by D B 17 days ago

Seems this was down to a hard to find memory problem that gave random errors.

Apologies

Actions #4

Updated by Jim Pingle 16 days ago

  • Status changed from Feedback to Not a Bug

No worries, thanks for following up and letting us know. Those kinds of problems can be quite frustrating to track down.

Actions

Also available in: Atom PDF