Project

General

Profile

Actions

Bug #12545

closed

/etc/inc/led.inc functions are not doing the right thing on 6100

Added by → luckman212 2 months ago. Updated 23 days ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
Hardware / Drivers
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Release Notes:
Default
Affected Plus Version:
22.01
Affected Architecture:
6100

Description

At various points of the boot process, the LEDs are supposed to flash with different patterns to indicate stages of boot- initializing interfaces, bootup complete, etc

On the 6100, I don't think these are working as expected. Mostly due to the /dev/led/* devices not matching this pattern which is at the top of /etc/inc/led.inc

$led_root = "/dev/led/led";

example, I believe the func below is supposed to set a single blue LED to "ON" and the others off, but it's not working on the 6100. At least as of 22.01.a.20211126.0600, it ends up with a slow blue blinking LED on the right side (diamond):

<code class="php">
led_normalize()
</code>

Actions #1

Updated by Jim Pingle 23 days ago

  • Status changed from New to Not a Bug
  • Target version deleted (22.01)

The LEDs on the 6100 and several other models are diven by GPIO and adjusted via a special script. They do not use the LED drivers handled via led.inc.

The script is at /usr/local/sbin/pfSense-led.sh on a pfSense Plus software installation, and gets called from various places in the Plus code appropriately.

Actions

Also available in: Atom PDF