Project

General

Profile

Actions

Bug #12637

closed

Incorrect SSH key permission after restore

Added by Viktor Gurov 6 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
High
Assignee:
Viktor Gurov
Category:
Backup / Restore
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
22.01
Release Notes:
Force Exclusion
Affected Version:
2.6.0
Affected Architecture:

Description

restore_sshdata() must set 600 permission mode for *_key files:

sshd[19401]: error: @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
sshd[19401]: error: @         WARNING: UNPROTECTED PRIVATE KEY FILE!          @
sshd[19401]: error: @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
sshd[19401]: error: Permissions 0644 for '/etc/ssh/ssh_host_rsa_key' are too open.
sshd[19401]: error: It is required that your private key files are NOT accessible by others.
sshd[19401]: error: This private key will be ignored.
sshd[19401]: error: Error loading host key "/etc/ssh/ssh_host_rsa_key": bad permissions
sshd[19401]: error: Could not load host key: /etc/ssh/ssh_host_rsa_key


Related issues

Related to Feature #11118: Backup and restore SSH host key(s)ResolvedViktor Gurov12/01/2020

Actions
Is duplicate of Bug #12640: problem with ssh host key permissions after restore from backup, sshd fails to startDuplicate

Actions
Actions #1

Updated by Viktor Gurov 6 months ago

Actions #3

Updated by Viktor Gurov 6 months ago

  • Related to Bug #12640: problem with ssh host key permissions after restore from backup, sshd fails to start added
Actions #4

Updated by Viktor Gurov 6 months ago

  • Related to deleted (Bug #12640: problem with ssh host key permissions after restore from backup, sshd fails to start)
Actions #5

Updated by Viktor Gurov 6 months ago

  • Is duplicate of Bug #12640: problem with ssh host key permissions after restore from backup, sshd fails to start added
Actions #6

Updated by Jim Pingle 6 months ago

  • Status changed from New to Pull Request Review
  • Assignee set to Viktor Gurov
  • Priority changed from Normal to High
  • Target version set to 2.6.0
  • Plus Target Version set to 22.01
Actions #7

Updated by Viktor Gurov 6 months ago

  • Status changed from Pull Request Review to Feedback
  • % Done changed from 0 to 100
Actions #8

Updated by Danilo Zrenjanin 6 months ago

  • Status changed from Feedback to Resolved

Tested against:

2.6.0-BETA (amd64)
built on Thu Dec 30 06:16:46 UTC 2021
FreeBSD 12.3-STABLE

Permissions look OK.

rw------ 1 root wheel 3389 Dec 31 10:29 ssh_host_rsa_key.
rw------ 1 root wheel 419 Dec 31 10:29 ssh_host_ed25519_key

I am marking this ticket resolved.

Actions

Also available in: Atom PDF