Project

General

Profile

Actions

Bug #12709

closed

RRD stats have many dropouts in all databases, with DHCPD RRD logging enabled and broken reverse DNS

Added by John Hood about 2 years ago. Updated about 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
RRD Graphs
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Default
Affected Version:
Affected Architecture:

Description

Seen on pfSense 2.5.2 Community Edition:

Since about 2021/03/01 I've had a problem where my RRD data has dropouts (shortly after 2.5.0 release, hmm). It seems to have been completely dead from about 2021/05/02 (shortly after 2.5.1 release, hmm) to 2021/11/05. Looking at the RRD databases directly shows lots of empty records.

Digging around, I found that I had dhcpd RRD logging enabled, which causes the generated updaterrd.sh to call /usr/local/bin/dhcpd_gather_stats.php , which was taking a minute+ to run on my system. It does gethostbyaddr() on each lease, and I did not have reverse DNS set up on the internal network, so gethostbyaddr() was stalled by a maybe 5 second timeout each time. Setting up reverse DNS seems to have resolved the issue. I don't know exactly how the long delay caused RRD stats collection to break.

This appears to have been fixed in master (and RELENG_2_6_0! yay!) for a different problem in bug #11512. So I believe this bug is actually a duplicate of that with rather different symptoms, and I'm posting it to help others who might have similar symptoms.

Bug #12338 is another thing that might or might not be connected to this.


Related issues

Has duplicate Regression #11512: DHCP Leases page and ARP table page fail to load if DNS is not availableClosedViktor Gurov02/23/2021

Actions
Actions #1

Updated by John Hood about 2 years ago

I installed
2.6.0-RC (amd64)
built on Thu Jan 20 19:49:04 UTC 2022

and broke reverse DNS again. The problem is fixed there, dhcpd_gather_stats.php runs with no delay.

Actions #2

Updated by Viktor Gurov about 2 years ago

  • Has duplicate Regression #11512: DHCP Leases page and ARP table page fail to load if DNS is not available added
Actions #3

Updated by Viktor Gurov about 2 years ago

  • Status changed from New to Duplicate

system_get_dhcpleases() fixed in #11512

Actions

Also available in: Atom PDF