Project

General

Profile

Bug #1309

Firmware upgrade

Added by Alex Vergilis about 8 years ago. Updated about 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Web Interface
Target version:
Start date:
02/26/2011
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

If a firmware upgrade is attempted through system_firmware_check.php, and the target url is unavailable, a non HTML friendly error message is produced as to the status of the update. A sample output of the problem is below:

\n
Not Found
\n

The requested URL /FreeBSD_RELENG_8_1/i386/pfSense_HEAD/.updaters//version was not found on this server.
\n\n\n Update source: http://snapshots.pfsense.org/FreeBSD_RELENG_8_1/i386/pfSense_HEAD/.updaters/\n"; this.document.forms0.output.scrollTop = this.document.forms0.output.scrollHeight;

Associated revisions

Revision 0f81d99a (diff)
Added by Scott Ullrich about 12 years ago

s/occured/occurred/

Ticket #1309

Revision 4ed69f33 (diff)
Added by Jim Pingle about 8 years ago

Do a more strict check on the return value of the download function. Fixes #1309

History

#1 Updated by Jim Pingle about 8 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#2 Updated by Alex Kennedy about 8 years ago

Feedback: Fixed.
Recommendation: Close ticket.

Findings:
Running RC1 build "Sat Feb 26 16:00:14 EST 2011" (i386 arch).

Changed value of the "Base URL" from "http://snapshots.pfsense.org/FreeBSD_RELENG_8_1/i386/pfSense_HEAD/.updaters/" to "http://thisdoesnotexistinthefarreachofthemind.net/path/to/files/". On invoking "system_firmware_check.php" The following "nice" error was thrown:

Downloading new version information...done
Unable to check for updates.
Could not contact custom update server.

"http://thisdoesnotexistinthefarreachofthemind.net/path/to/files/" was chosen to fulfill the requirement of "the target url is unavailable" specified in the ticket description. Because no example was given, I chose to do a worst case scenario where not even the DNS entry is specified. The following shows this domain as a candidate under these revised requirements:

; <<>> DiG 9.6.0-APPLE-P2 <<>> @8.8.8.8 thisdoesnotexistinthefarreachofthemind.net. ANY
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 8760
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;thisdoesnotexistinthefarreachofthemind.net. IN ANY

;; AUTHORITY SECTION:
net.            886    IN    SOA    a.gtld-servers.net. nstld.verisign-grs.com. 1298926114 1800 900 604800 86400

;; Query time: 50 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Mon Feb 28 12:49:22 2011
;; MSG SIZE  rcvd: 133

Let me know if you need any other information.

#3 Updated by Chris Buechler about 8 years ago

  • Status changed from Feedback to Resolved

thanks

Also available in: Atom PDF