Project

General

Profile

Actions

Regression #13162

closed

Upgrade does not work when using only IPv6 DNS servers

Added by Sietse van Zanen about 2 months ago. Updated 26 days ago.

Status:
Resolved
Priority:
Low
Assignee:
Viktor Gurov
Category:
Upgrade
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
22.05
Release Notes:
Default
Affected Version:
2.6.0
Affected Architecture:
All

Description

When only IPv6 DNS servers are used (in general config) GUI update is not functional.
Following message is displayed when checking for updates in the GUI:
Retrieving: Unable to check for updates.
Unfortunately I have not been able to find any logs of this.

running pfSense-upgrade from cli works fine.
Adding one IPV4 dns server, no matter which order will make the GUI check functional.


Related issues

Related to Regression #11512: DHCP Leases page and ARP table page fail to load if DNS is not availableClosedViktor Gurov02/23/2021

Actions
Related to Bug #12141: Lack of DNS or Internet connectivity causes GUI to be slowResolvedViktor Gurov07/17/2021

Actions
Actions #1

Updated by Viktor Gurov about 2 months ago

  • Related to Regression #11512: DHCP Leases page and ARP table page fail to load if DNS is not available added
Actions #2

Updated by Viktor Gurov about 2 months ago

  • Tracker changed from Bug to Regression
Actions #3

Updated by Viktor Gurov about 2 months ago

  • Related to Bug #12141: Lack of DNS or Internet connectivity causes GUI to be slow added
Actions #4

Updated by Viktor Gurov about 2 months ago

  • Assignee set to Viktor Gurov
  • Target version set to 2.7.0
  • Plus Target Version set to 22.05
Actions #5

Updated by Jim Pingle about 2 months ago

  • Status changed from New to Pull Request Review
Actions #6

Updated by Viktor Gurov about 2 months ago

  • Status changed from Pull Request Review to Feedback
  • % Done changed from 0 to 100
Actions #7

Updated by Jim Pingle about 1 month ago

  • Subject changed from GUI Update not working when using only ipv6 DNS servers to Upgrade does not work when using only IPv6 DNS servers

Updating subject for release notes.

Actions #8

Updated by Jim Pingle 26 days ago

  • Status changed from Feedback to Resolved

Seems to be fixed. On 22.01 if I set only IPv6 DNS and tell the GUI to only use remote DNS, the update check does fail.

Same setup on 22.05 works.

Actions

Also available in: Atom PDF