Project

General

Profile

Actions

Bug #13170

closed

Internet (IPV6-)connectivity gone due to renaming WAN-interface

Added by Louis van Breda about 1 month ago. Updated about 1 month ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
Interfaces
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Default
Affected Version:
All
Affected Architecture:
All

Description

Hello,

Yesterday I discovered that my IPV6 was not working any longer, despite the fact the both IPV4 and IPV6-gateways are indicated OK on the dashboard.

After significant testing and comparing config files (old OK versions with the actual and first NOK one), I noticed that data blocks in the actual config file where still referring to the old wan-name.

With global search and replace with a text editor I could fix this IPV6-connectivity issue.
Not sure if I fixed all and also not sure about the impact of renaming other interfaces.

This issue probably affect a lot of pfSense CE and Plus versions (if you dare to rename the wan)

What makes this serious next to that this happens, is that on the dashboard every thing seems to be OK, and assuming you also have IPV4 it is not immediately clear that you have a very serious problem .....


Files

REFERENCE_CE27_config-pfSense.lan-20220516153128.xml (528 KB) REFERENCE_CE27_config-pfSense.lan-20220516153128.xml This is my actual config. IPV6 OK Louis van Breda, 05/16/2022 08:49 AM
CONFIG_WITH_CHANGES_WANNAME NO IPV6 config-pfSense.lan-20220516154409.xml (528 KB) CONFIG_WITH_CHANGES_WANNAME NO IPV6 config-pfSense.lan-20220516154409.xml This is the same config with WAN named WAN_TEST => IPV6 GONE Louis van Breda, 05/16/2022 08:50 AM
Actions #1

Updated by Jim Pingle about 1 month ago

  • Subject changed from Internet (IPV6-)connectivity gone due to renaming WAN-interface :( to Internet (IPV6-)connectivity gone due to renaming WAN-interface
  • Category changed from Configuration Backend to Interfaces
  • Status changed from New to Incomplete
  • Target version deleted (2.7.0)

There isn't nearly enough information here to classify this as a bug. The interface name itself isn't referenced anywhere directly except maybe as a part of a dynamic gateway name or something like a traffic graph data file. From what little information you have provided it's not clear if that's the case, and that wouldn't break connectivity in general.

This site is not for support or diagnostic discussion.

For assistance in solving problems, please post on the Netgate Forum or the pfSense Subreddit .

If, after diagnosing it further on the forum, a reproducible bug is found, then a more accurate and complete issue can be created.

See Reporting Issues with pfSense Software for more information.

Actions #2

Updated by Louis van Breda about 1 month ago

Jim, could you please take me serious!

Hereby two config files:
- my actual config and
- the same config with the WAN name renamed from WAN to WAN_TEST

With the first one IPV6 works, with the second one NOT !!

If you look into the config file you will notice that dhcp and other things are referring with a name to the WAN.

By the way I would have preferred to share the attached files in a private way. Perhapse you could remove them after saving!

Actions #3

Updated by Jim Pingle about 1 month ago

  • Status changed from Incomplete to Not a Bug

The internal name "wan" has nothing to do with your custom name "WAN" or "WAN_TEST".

The only references I see which use the custom "WAN" name (uppercase) are gateways as I suspected. Likely all you need to do is re-select the default IPv4/IPv6 gateways to ensure they are using the correct (new) dynamic gateway name. There is no support for renaming a gateway either manually or automatically.

Either way this isn't the place to diagnose your problem as I mentioned.

Actions

Also available in: Atom PDF