Project

General

Profile

Actions

Bug #13213

closed

allow no-lan configurations

Added by Alex Kolesnik about 1 month ago. Updated about 1 month ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
Interfaces
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Default
Affected Version:
All
Affected Architecture:

Description

The scenario:
pfSense is launched in a cloud provider (like AWS or Hetzner). By default there's only one interface - WAN. There's no way to assign the 1st IPSec P2 VTI to an OPT interface. It's always assigned to the LAN (/usr/local/www/interfaces_assign.php):
/* find next free optional interface number */
if (!$config['interfaces']['lan']) {
$newifname = "lan";
$descr = "LAN";
} else {
for ($i = 1; $i <= count($config['interfaces']); $i++) {
if (!$config['interfaces']["opt{$i}"]) {
break;
}
}
$newifname = 'opt' . $i;
$descr = "OPT" . $i;
}

Actions #1

Updated by Jim Pingle about 1 month ago

  • Status changed from New to Not a Bug

That is just the default interface label. You can rename that to whatever you want. Anything else it triggers you can account for in other settings.

Actions

Also available in: Atom PDF