Project

General

Profile

Actions

Bug #13231

closed

OpenVPN custom options may fail after save/restore

Added by Danilo Zrenjanin 30 days ago. Updated 27 days ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
OpenVPN
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Default
Affected Version:
Affected Architecture:

Description

Sometimes after restoring a backup XML file, custom options get formatted improperly. That prevents the OpenVPN service from starting.

The same fix may be applied. Please see the link below for more details:
https://redmine.pfsense.org/issues/13105 for more details.

Actions #1

Updated by Jim Pingle 27 days ago

  • Status changed from New to Not a Bug
  • Target version deleted (CE-Next)
  • Plus Target Version deleted (Plus-Next)

OpenVPN directives are to be separated by semicolons, not newlines. That's stated in the text above the box and in the docs. It's always been that way. Anything else may happen to work by accident but as stated here, it's not reliable, hence the semicolons.

We could maybe consider changing that in the future as a feature request but as it stands there is no bug here.

Actions

Also available in: Atom PDF