Project

General

Profile

Actions

Bug #13232

closed

Restoring Config with OpenVPN Custom Options Removes Carriage Returns

Added by Kris Phillips 29 days ago. Updated 28 days ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Web Interface
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Release Notes:
Default
Affected Plus Version:
Affected Architecture:
All

Description

If you back up a config on one device and then restore it in another, if you have an OpenVPN client (potentially server as well) that has custom options with carriage returns for each line, the carriage returns are removed and the config will fail to work due to spacing issues.


Related issues

Is duplicate of Bug #12641: OpenVPN GUI Config Editor removes newlines of "Custom options" field in parsingNot a Bug

Actions
Actions #1

Updated by Marcos Mendoza 28 days ago

  • Status changed from New to Duplicate

This seems more like a feature than a bug, considering that the description and documentation both say to separate with semicolon, not new lines.
https://docs.netgate.com/pfsense/en/latest/vpn/openvpn/configure-server-advanced.html#custom-options

Actions #2

Updated by Marcos Mendoza 28 days ago

  • Is duplicate of Bug #12641: OpenVPN GUI Config Editor removes newlines of "Custom options" field in parsing added
Actions

Also available in: Atom PDF