Project

General

Profile

Actions

Regression #13618

closed

Creating URL Table (IPs) alias fails on applying

Added by Brad Smith 3 months ago. Updated 2 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
Aliases / Tables
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Default
Affected Version:
2.7.0
Affected Architecture:
All

Description

Creating URL Table (IPs) alias fails on applying

It just eventually times out and nothing has been created. Tried Oct 26 and 31 builds.


Files


Related issues

Is duplicate of Regression #13685: URL alias parsing is broken, gets stuck in infinite loop reading downloaded fileResolvedJim Pingle

Actions
Actions #1

Updated by Chris W 3 months ago

Confirmed on build 2.7.0.a.20221104.0600

In Firewall > Alias, I added five URL type aliases. Clicked save and PHP-FPM CPU use spiked to 100% and the settings were never applied. Eventually the browser tab refreshed with a 504 Gateway Time-out and PHP-FPM continued to use 99 - 100% of a CPU thread.

Actions #2

Updated by Brad Smith 2 months ago

This appears to be resolved now. I update around once a week on my test system so unsure which build fixed it.

Actions #3

Updated by Jim Pingle 2 months ago

  • Status changed from Confirmed to Duplicate
  • Assignee set to Jim Pingle

I missed this issue and ended up making a new one when I fixed it. See #13685

Actions #4

Updated by Jim Pingle 2 months ago

  • Is duplicate of Regression #13685: URL alias parsing is broken, gets stuck in infinite loop reading downloaded file added
Actions

Also available in: Atom PDF