Project

General

Profile

Actions

Bug #13623

closed

Snort binary package fails to install on 2.7.0-DEVEL snapshots due to luajit-openresty version problems

Added by Bill Meeks 3 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Snort
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Affected Version:
2.7.0
Affected Plus Version:
23.01
Affected Architecture:
All

Description

The Snort package binary piece (snort-2.9.20_1) fails to install on the latest 2.7.0-DEVEL snapshot due to an apparent issue with luajit-openresty and/or other LUA components. I am the Snort package maintainer, but I will need some assistance from the Netgate developer team to get this one sorted out. Brad Davis may be the correct person to help out.

Here is the full package installation log with the error at the end:

>>> Installing pfSense-pkg-snort...

Updating pfSense-core repository catalogue...
pfSense-core repository is up to date.
Updating pfSense repository catalogue...
pfSense repository is up to date.
All repositories are up to date.
The following 6 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
    daq: 2.2.2_3 [pfSense]
    libdnet: 1.13_3 [pfSense]
    libpcap: 1.10.1_2 [pfSense]
    luajit-devel: 2.1.0.20221004_1 [pfSense]
    pfSense-pkg-snort: 4.1.6_1 [pfSense]
    snort: 2.9.20_1 [pfSense]

Number of packages to be installed: 6

The process will require 13 MiB more space.
3 MiB to be downloaded.
[1/6] Fetching libdnet-1.13_3.pkg: .......... done
[2/6] Fetching snort-2.9.20_1.pkg: .......... done
[3/6] Fetching luajit-devel-2.1.0.20221004_1.pkg: .......... done
[4/6] Fetching daq-2.2.2_3.pkg: .......... done
[5/6] Fetching libpcap-1.10.1_2.pkg: .......... done
[6/6] Fetching pfSense-pkg-snort-4.1.6_1.pkg: .......... done
Checking integrity... done (1 conflicting)
  - luajit-devel-2.1.0.20221004_1 [pfSense] conflicts with luajit-openresty-2.1.20220411 [installed] on /usr/local/bin/luajit
Checking integrity... done (0 conflicting)
Conflicts with the existing packages have been found.
One more solver iteration is needed to resolve them.
The following 8 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
    daq: 2.2.2_3 [pfSense]
    libdnet: 1.13_3 [pfSense]
    libpcap: 1.10.1_2 [pfSense]
    luajit-devel: 2.1.0.20221004_1 [pfSense]
    pfSense-pkg-snort: 4.1.6_1 [pfSense]
    snort: 2.9.20_1 [pfSense]

Number of packages to be installed: 6

The process will require 13 MiB more space.
Fetching luajit-openresty-2.1.20220915.pkg: .......... done
[1/8] Deinstalling luajit-openresty-2.1.20220411...
[1/8] Deleting files for luajit-openresty-2.1.20220411: ...
luajit-openresty-2.1.20220411: missing file /usr/local/man/man1/luajit.1.gz
[1/8] Deleting files for luajit-openresty-2.1.20220411.......... done
[2/8] Installing libdnet-1.13_3...
[2/8] Extracting libdnet-1.13_3: .......... done
[3/8] Installing libpcap-1.10.1_2...
[3/8] Extracting libpcap-1.10.1_2: .......... done
[4/8] Installing luajit-devel-2.1.0.20221004_1...
[4/8] Extracting luajit-devel-2.1.0.20221004_1: .......... done
[5/8] Installing daq-2.2.2_3...
[5/8] Extracting daq-2.2.2_3: .......... done
[6/8] Installing snort-2.9.20_1...
[6/8] Extracting snort-2.9.20_1: .......... done
[6/8] Installing luajit-openresty-2.1.20220915...
pkg-static: luajit-openresty-2.1.20220915 conflicts with luajit-devel-2.1.0.20221004_1 (installs files into the same place).  Problematic file: /usr/local/bin/luajit
Failed
Actions #1

Updated by Bill Meeks 3 months ago

Found the change in upstream FreeBSD ports that likely caused this issue: [https://reviews.freebsd.org/D36947?id=111687].

That commit in FreeBSD then led to this change in the Snort binary in upstream FreeBSD ports: [https://www.freshports.org/commit.php?category=security&port=snort&files=yes&message_id=84778f95757e53e2b2bb7bb7a24e9a9fda2b60a6].

Not sure how, but the changes upstream resulted in binary packages on pfSense 2.7.0-DEVEL attempting to install a slightly newer version of luajit-openresty than already exists on the system -- version luajit-openresty-2.1.20220915 exists, but the Snort binary attempts to install luajit-openresty-2.1.0.20221004_1.

Actions #2

Updated by Kris Phillips 3 months ago

  • Status changed from New to Confirmed

I can confirm this bug report. Installation log matches on Nov 4th builds:

Installing pfSense-pkg-snort...

Updating pfSense-core repository catalogue...
pfSense-core repository is up to date.
Updating pfSense repository catalogue...
pfSense repository is up to date.
All repositories are up to date.
The following 6 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
daq: 2.2.2_3 [pfSense]
libdnet: 1.13_3 [pfSense]
libpcap: 1.10.1_2 [pfSense]
luajit-devel: 2.1.0.20221004_1 [pfSense]
pfSense-pkg-snort: 4.1.6_1 [pfSense]
snort: 2.9.20_1 [pfSense]

Number of packages to be installed: 6

The process will require 13 MiB more space.
3 MiB to be downloaded.
[1/6] Fetching libdnet-1.13_3.pkg: .......... done
[2/6] Fetching snort-2.9.20_1.pkg: .......... done
[3/6] Fetching luajit-devel-2.1.0.20221004_1.pkg: .......... done
[4/6] Fetching daq-2.2.2_3.pkg: .......... done
[5/6] Fetching libpcap-1.10.1_2.pkg: .......... done
[6/6] Fetching pfSense-pkg-snort-4.1.6_1.pkg: .......... done
Checking integrity... done (1 conflicting)
- luajit-devel-2.1.0.20221004_1 [pfSense] conflicts with luajit-openresty-2.1.20220915 [installed] on /usr/local/bin/luajit
Checking integrity... done (0 conflicting)
Conflicts with the existing packages have been found.
One more solver iteration is needed to resolve them.
The following 8 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
daq: 2.2.2_3 [pfSense]
libdnet: 1.13_3 [pfSense]
libpcap: 1.10.1_2 [pfSense]
luajit-devel: 2.1.0.20221004_1 [pfSense]
pfSense-pkg-snort: 4.1.6_1 [pfSense]
snort: 2.9.20_1 [pfSense]

Number of packages to be installed: 6

The process will require 13 MiB more space.
Fetching luajit-openresty-2.1.20220915.pkg: .......... done
[1/8] Deinstalling luajit-openresty-2.1.20220915...
[1/8] Deleting files for luajit-openresty-2.1.20220915: .......... done
[2/8] Installing libdnet-1.13_3...
[2/8] Extracting libdnet-1.13_3: .......... done
[3/8] Installing libpcap-1.10.1_2...
[3/8] Extracting libpcap-1.10.1_2: .......... done
[4/8] Installing luajit-devel-2.1.0.20221004_1...
[4/8] Extracting luajit-devel-2.1.0.20221004_1: .......... done
[5/8] Installing daq-2.2.2_3...
[5/8] Extracting daq-2.2.2_3: .......... done
[6/8] Installing snort-2.9.20_1...
[6/8] Extracting snort-2.9.20_1: .......... done
[6/8] Installing luajit-openresty-2.1.20220915...
pkg-static: luajit-openresty-2.1.20220915 conflicts with luajit-devel-2.1.0.20221004_1 (installs files into the same place). Problematic file: /usr/local/bin/luajit
Failed

Actions #3

Updated by Bill Meeks 3 months ago

I also forgot to add that I do not think this luajit library issue is restricted to just Snort. I suspect any package in the pfSense ports tree that depends on the luajit library is going to experience the same issue when installing/updating.

Actions #4

Updated by Bill Meeks 2 months ago

I have submitted a pull request to the pfSense DEVEL FreeBSD-ports tree to correct this issue. Here is the link: https://github.com/pfsense/FreeBSD-ports/pull/1195.

Once the pull request is reviewed and merged, this issue can be marked resolved.

Actions #5

Updated by Kris Phillips 2 months ago

  • Status changed from Confirmed to Resolved

This looks like it was merged, so I tested on the latest builds.

Issue is no longer present and the package installs normally.

Marking as Resolved.

Actions

Also available in: Atom PDF