Project

General

Profile

Actions

Bug #13709

closed

Suricata 6.0.6_1 - PHP 8.1 Error on Alerts Page

Added by Steve Wilson 2 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Suricata
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Affected Version:
Affected Plus Version:
23.01
Affected Architecture:
amd64

Description

Seeing this error upon clicking on the Suricata alerts tab:

"Parse error: syntax error, unexpected token ";" in /usr/local/www/suricata/suricata_alerts.php on line 546"

Suricata version 6.0.6_1

pfSense version:

23.01-DEVELOPMENT (amd64)
built on Tue Nov 29 06:04:48 UTC 2022
FreeBSD 14.0-CURRENT

Actions #1

Updated by Bill Meeks 2 months ago

Confirmed.

This is caused by a missing closing parenthesis in the if() conditional statement on line 545 directly above 546 in /usr/local/www/suricata/suricata_alerts.php . I will submit a fix for this.

Actions #2

Updated by Bill Meeks 2 months ago

I've submitted a pull request to the 2.7.0 CE snapshot development branch to address this issue. The request is here: https://github.com/pfsense/FreeBSD-ports/pull/1198. Once this request is approved and merged, this issue can be marked as resolved.

Actions #3

Updated by Bill Meeks 2 months ago

The pull request has been merged. This issue can be marked as resolved.

Actions #4

Updated by Kris Phillips about 2 months ago

  • Status changed from New to Resolved

Tested with Suricata 6.0.8_2. Not seeing PHP error messages on the Alerts page. Looks to be resolved.

Actions

Also available in: Atom PDF