Project

General

Profile

Actions

Regression #13999

closed

PHP error in NTP widget and status with GPS data

Added by anthony mushamel over 1 year ago. Updated 12 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
NTPD
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
23.05
Release Notes:
Default
Affected Version:
2.7.0
Affected Architecture:
amd64

Description

I have had this issue since the beta and I am still having it on 23.01 final.
I put the NTP widget on my home screen and it works fine. After a bit of time or a refresh of the page, I get the following error

Fatal error: Uncaught TypeError: Unsupported operand types: string / float in /usr/local/www/widgets/widgets/ntp_status.widget.php:121 Stack trace: #0 {main} thrown in /usr/local/www/widgets/widgets/ntp_status.widget.php on line 121 PHP ERROR: Type: 1, File: /usr/local/www/widgets/widgets/ntp_status.widget.php, Line: 121, Message: Uncaught TypeError: Unsupported operand types: string / float in /usr/local/www/widgets/widgets/ntp_status.widget.php:121 Stack trace: #0 {main} thrown

Here is the crash report
Crash report begins. Anonymous machine information:

amd64
14.0-CURRENT
FreeBSD 14.0-CURRENT #0 plus-RELENG_23_01-n256037-6e914874a5e: Fri Feb 10 20:30:29 UTC 2023 root@freebsd:/var/jenkins/workspace/pfSense-Plus-snapshots-23_01-main/obj/amd64/VDZvZksF/var/jenkins/workspace/pfSense-Plus-snapshots-23_01-main/sources/FreeBS

Crash report details:

PHP Errors:
[20-Feb-2023 15:09:15 America/Los_Angeles] PHP Fatal error: Uncaught TypeError: Unsupported operand types: string / float in /usr/local/www/widgets/widgets/ntp_status.widget.php:121
Stack trace:
#0 {main}
thrown in /usr/local/www/widgets/widgets/ntp_status.widget.php on line 121

No FreeBSD crash data found.

Actions #1

Updated by Jim Pingle over 1 year ago

  • Tracker changed from Bug to Regression
  • Subject changed from NTP Widget suffers from PHP Fatal Error to PHP error in NTP widget/status with GPS data.
  • Status changed from New to In Progress
  • Assignee set to Jim Pingle
  • Target version set to 2.7.0
  • Affected Plus Version changed from 23.01 to 22.05

Looks like the exact same crash can happen on status_ntpd.php, both seem to need a GPS module present to trigger.

Actions #2

Updated by Jim Pingle over 1 year ago

  • Category changed from Dashboard to NTPD
Actions #3

Updated by Jim Pingle over 1 year ago

  • Status changed from In Progress to Feedback
  • % Done changed from 0 to 100
Actions #4

Updated by Jim Pingle over 1 year ago

  • Project changed from pfSense Plus to pfSense
  • Subject changed from PHP error in NTP widget/status with GPS data. to PHP error in NTP widget and status with GPS data
  • Category changed from NTPD to NTPD
  • Affected Plus Version deleted (22.05)
  • Plus Target Version set to 23.05
Actions #5

Updated by Jim Pingle about 1 year ago

  • Status changed from Feedback to Resolved

No crashes on current snapshots with a GPS-enabled NTP config. Both widget and status page show GPS data and link to maps.

Actions #6

Updated by Jim Pingle 12 months ago

  • Affected Version set to 2.7.0
Actions

Also available in: Atom PDF