Project

General

Profile

Actions

Bug #1403

closed

Filter Rules description do not get saved when "(quote) present as character

Added by Ermal Luçi over 10 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Web Interface
Target version:
Start date:
03/31/2011
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.0
Affected Architecture:

Description

Topic says it all.
Some investigation is needed to find the cause.

Actions #1

Updated by Chris Buechler over 10 years ago

under what circumstances is this a problem? The input validation doesn't allow quotes in rule descriptions.

Actions #2

Updated by Jim Pingle over 10 years ago

It looks like you can save a NAT rule with a " in the description, which could get you a filter rule with a " in the description, which then can't be saved. However the error message still clearly states that the problem is with the " and it can be easily removed.

The NAT rule edit pages should probably also be set to kick back a description with a " though if it really is a problem.

Actions #4

Updated by Ermal Luçi over 10 years ago

  • Status changed from New to Closed

It happened to me in a VM.
Not really sure on the circumstances, though if i can reproduce again i will check more the details.
I tested now and the quotes are allowed but are saved escaped and surrounded by CDATA on xml.

I am closing for now and if i stomp on it again will get details.

Actions

Also available in: Atom PDF