Project

General

Profile

Actions

Regression #14057

closed

Dynamic gateway names use mixed case instead of upper case, leading to configuration mismatches

Added by Jim Pingle about 1 year ago. Updated 10 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Gateways
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
23.05
Release Notes:
Default
Affected Version:
2.7.0
Affected Architecture:

Description

Somewhere between 22.05.x and 23.01 dynamic gateway names started to come out as mixed case instead of being forced to upper case. This depends on the value of the interface description, so only users with mixed case interface descriptions would notice it. For example "WAN2" wouldn't see it, but "WAN_Cable" would.

The problem is users may have the default gateway, gateway group members, policy routing rules, and so on using the old all-caps names which now do not match an existing gateway.

Actions #1

Updated by Jim Pingle about 1 year ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100
Actions #2

Updated by Christopher Cope about 1 year ago

  • Status changed from Feedback to Resolved

Tested on

23.05-DEVELOPMENT (amd64)
built on Fri Mar 03 06:04:04 UTC 2023
FreeBSD 14.0-CURRENT

Dynamic gateway names are now forced uppercase, as expected. Marking Resolved.

Actions #3

Updated by Jim Pingle 10 months ago

  • Affected Version set to 2.7.0
Actions

Also available in: Atom PDF