Project

General

Profile

Bug #1428

DNS servers not assigned

Added by Lloyd Collins about 8 years ago. Updated about 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
DNS Forwarder
Target version:
Start date:
04/09/2011
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

I just updated my PFsense install to the latest version (2.0-RC1 (i386)built on Fri Apr 8 18:33:38 EDT 2011) and DNS servers fron the wan interface are no longer being acknowledged or used. This only started after updating.

Associated revisions

Revision 4eb4b18a (diff)
Added by Jim Pingle about 8 years ago

Revert changes to dhclient-script. Appears to have broken DNS servers from DHCP. Ticket #1428

History

#1 Updated by Jim Pingle about 8 years ago

Not enough info here. Are these assigned manually? By DHCP? Any errors in the logs or console?

#2 Updated by Lloyd Collins about 8 years ago

They should be assigned via DHCP by the ISP but PFSense will not accept them so I have assigned them manually in general setup to get WAN access back. There are no visible errors in the logs. For your reference I will paste below the logs made once the DNS server addresses are removed:

Note: these are in newest on top order.

Apr 9 18:31:22 check_reload_status: reloading filter
Apr 9 18:31:07 php: /system.php: The command '/usr/bin/killall 'ntpd'' returned exit code '1', the output was 'killall: warning: kill -TERM 34609: No such process'
Apr 9 18:31:07 dnsmasq34917: read /etc/hosts - 12 addresses
Apr 9 18:31:07 dhcpd: For info, please visit https://www.isc.org/software/dhcp/
Apr 9 18:31:07 dhcpd: All rights reserved.
Apr 9 18:31:07 dhcpd: Copyright 2004-2010 Internet Systems Consortium.
Apr 9 18:31:07 dhcpd: Internet Systems Consortium DHCP Server 4.1.1-P1
Apr 9 18:31:07 dnsmasq34917: read /etc/hosts - 12 addresses
Apr 9 18:31:05 dnsmasq34917: read /etc/hosts - 12 addresses
Apr 9 18:31:05 dnsmasq34917: read /etc/hosts - 12 addresses
Apr 9 18:31:05 dnsmasq34917: no servers found in /etc/resolv.conf, will retry
Apr 9 18:31:05 dnsmasq34917: no servers found in /etc/resolv.conf, will retry
Apr 9 18:31:05 dnsmasq34917: compile time options: IPv6 GNU-getopt no-DBus I18N DHCP TFTP
Apr 9 18:31:05 dnsmasq34917: started, version 2.55 cachesize 10000
Apr 9 18:31:05 dhcpleases: Could not deliver signal HUP to process because its pidfile does not exist, No such process.
Apr 9 18:31:04 dnsmasq63803: exiting on receipt of SIGTERM
Apr 9 18:31:04 dnsmasq63803: read /etc/hosts - 12 addresses
Apr 9 18:31:04 dhcpd: For info, please visit https://www.isc.org/software/dhcp/
Apr 9 18:31:04 dhcpd: All rights reserved.
Apr 9 18:31:04 dhcpd: Copyright 2004-2010 Internet Systems Consortium.
Apr 9 18:31:04 dhcpd: Internet Systems Consortium DHCP Server 4.1.1-P1
Apr 9 18:31:04 dnsmasq63803: read /etc/hosts - 12 addresses
Apr 9 18:31:02 dnsmasq63803: read /etc/hosts - 12 addresses
Apr 9 18:31:02 dnsmasq63803: read /etc/hosts - 12 addresses
Apr 9 18:31:02 dnsmasq63803: no servers found in /etc/resolv.conf, will retry
Apr 9 18:31:02 dnsmasq63803: no servers found in /etc/resolv.conf, will retry
Apr 9 18:31:02 check_reload_status: syncing firewall
Apr 9 18:28:29 syslogd: kernel boot file is /boot/kernel/kernel
Apr 9 18:28:29 syslogd: exiting on signal 15
Apr 9 18:28:29 check_reload_status: syncing firewall

No console errors are provided.

Sorry for not providing this in the beginning. Please let me know if you need anything more.

#3 Updated by Chris Buechler about 8 years ago

  • Priority changed from Urgent to Normal

need dhclient logs, that just looks like you aren't being assigned DHCP servers.

#4 Updated by Chuck Evangelista about 8 years ago

Same problem here after update... ISP DNS servers not applied. Had to enter DNS servers manually.

2.0-RC1 (i386)
built on Fri Apr 8 18:33:38 EDT 2011

#5 Updated by Jim Pingle about 8 years ago

  • Status changed from New to Resolved

I was able to reproduce this, and committed a fix on Saturday. This is fixed on current snapshots, and confirmed with the VM I used to reproduce the issue.

Also available in: Atom PDF