Project

General

Profile

Actions

Bug #14643

closed

Suricata PHP error after upgrade to CE 2.7.0

Added by e 1/1 11 months ago. Updated 10 months ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
Suricata
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Affected Version:
2.7.0
Affected Plus Version:
Affected Architecture:
amd64

Description

First login after upgrading to 2.7.0, a couple of PHP error notices are shown, one of them related to Suricata:

PHP ERROR: Type: 64, File: /usr/local/pkg/suricata/suricata_generate_yaml.php, Line: 396, Message: Unparenthesized `a ? b : c ? d : e` is not supported. Use either `(a ? b : c) ? d : e` or `a ? b : (c ? d : e)`

No loss of functionality noticed, though.

Actions #1

Updated by Christopher Cope 10 months ago

  • Status changed from New to Not a Bug

That is expected as the system upgrades the packages. Since it is working correctly after the upgrade, I'm marking this as not a bug.

Actions

Also available in: Atom PDF