Project

General

Profile

Actions

Bug #14711

closed

pfBlocker ASN to IP Address option doesn't work

Added by Danilo Zrenjanin 11 months ago. Updated 10 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
pfBlockerNG
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Affected Version:
Affected Plus Version:
Affected Architecture:

Description

pfBlocker relies on Team Cymru IP to ASN Lookup v1.0 to get the list of prefixes for the defined ASN. But it seems that it is not working anymore.
https://asn.cymru.com/

Steps to reproduce:
1.) Navigate to Firewall/pfBlockerNG/IP/IPv4 
2.) Define *IPv4 Source Definitions* choosing *ASN* format and define Facebook ASN (AS32934). (It can hang and make trouble defining ASN. See https://redmine.pfsense.org/issues/12822 for more details. 
3.) On the same page, under the *Settings* section, choose *Alias Native* in the *Action* drop-down list.
4.) Save the settings on the bottom of the page.
5.) Go to Firewall/pfBlockerNG/Update and run the update. 
6.) At this stage, the firewall will have a new Alias from the Source Definition made in step 2.) but if you check it under Diagnostics/Tables, you'll notice that it's empty.
Actions #1

Updated by Lev Prokofev 11 months ago

  • Status changed from New to Confirmed

Tested on pfBlocker 3.2.0_6

It failed to load list.

[ AS32934_v4 ]             Reload . completed ..
  Empty file, Adding '127.1.7.7' to avoid download failure.

Marking this as confirmed.

Actions #2

Updated by Hayden Hill 10 months ago

I can confirm this is an issue. ASN lookup no longer working for me.

Actions #3

Updated by Hayden Hill 10 months ago

For those looking for a workaround for now I found this. Can use it to pull a JSON.

https://github.com/ipverse/asn-ip

Actions #4

Updated by Hayden Hill 10 months ago

It seems to be working again for me!

Actions #5

Updated by Danilo Zrenjanin 10 months ago

Yes, I can confirm it works again.

===[  Aliastables / Rules  ]==========================================

No changes to Firewall rules, skipping Filter Reload

 Updating: pfB_Facebook_v4
1 table created.131 addresses added.

 UPDATE PROCESS ENDED [ 09/14/23 09:35:23 ]
Actions #6

Updated by Danilo Zrenjanin 10 months ago

  • Status changed from Confirmed to Resolved

I am marking this case resolved.

Actions

Also available in: Atom PDF