Project

General

Profile

Actions

Regression #14736

closed

Unable to select PFS Group for individual Phase 2 configurations if Mobile Client global override is not selected

Added by Kev Kitchens 8 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
IPsec
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
23.09
Release Notes:
Force Exclusion
Affected Version:
2.8.0
Affected Architecture:

Description

In the currently nightly snapshot, I'm unable to select a PFS group for an individual Phase 2 configuration unless the global override in the Mobile Clients section is also enabled. When the global override option is disabled, the PFS group selection menu in the Phase 2 configuration screen is also disabled and the label reads "Set globally in mobile client options" From the documentation, this behavior seems to be the opposite from what is expected and how the system behaved previously (which is why I've marked this as a regression). Notably, when the global override is disabled the element configuring it is removed from strongswan.conf as expected, but the previously selected PFS group for the individual Phase 2 is still present in the configured proposal in swanctl.conf even though the value can no longer be changed in the UI.

Actions #1

Updated by Jim Pingle 8 months ago

  • Status changed from New to Confirmed
  • Target version set to 2.8.0
  • Plus Target Version set to 23.09
  • Release Notes changed from Default to Force Exclusion

I saw that the other day as well but hadn't got around to trying it again or creating a redmine. Probably some logic got altered during refactoring.

Actions #2

Updated by Jim Pingle 7 months ago

  • Status changed from Confirmed to In Progress
  • Assignee set to Jim Pingle
Actions #3

Updated by Jim Pingle 7 months ago

  • Status changed from In Progress to Feedback
  • % Done changed from 0 to 100
Actions #4

Updated by Danilo Zrenjanin 7 months ago

Tested on :

23.09-DEVELOPMENT (amd64)
built on Thu Sep 07 06:05:43 UTC 2023
FreeBSD 14.0-ALPHA2

It works as expected.

I am marking this case resolved.

Actions #5

Updated by Danilo Zrenjanin 7 months ago

  • Status changed from Feedback to Resolved
Actions #6

Updated by Jim Pingle 5 months ago

  • Target version changed from 2.8.0 to 2.7.1
Actions

Also available in: Atom PDF