Project

General

Profile

Actions

Regression #14791

closed

``/etc/version.buildtime`` is not being updated on current snapshots

Added by Jim Pingle 7 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Build / Release
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
23.09
Release Notes:
Force Exclusion
Affected Version:
Affected Architecture:

Description

The file /etc/version.buildtime used to be a part of the pfSense-base package base.txz file, but it isn't there any longer. It's also not in the pfSense package where other version files moved (e.g. /etc/version).

Among other uses, the dashboard uses this file to display the "built on" timestamp in the system information widget. Currently even if an update to a new snapshot succeeded, the dashboard is showing an old timestamp since there is no new copy of the file.

It either needs to get back into the base.txz file or moved into the pfSense package.

Actions #1

Updated by Jim Pingle 7 months ago

  • Release Notes changed from Default to Force Exclusion
Actions #2

Updated by Jim Pingle 7 months ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

Brad put a fix in for this: https://github.com/pfsense/FreeBSD-ports/commit/11fd487e5b135b73d613fd9809e5303463254d8e + e7a1c9b4c8130a60c9351024fc74eaac9fcc37e6

Actions #3

Updated by Marcos M 7 months ago

The version is being updated, but the version string is now different.

cat /etc/version.buildtime
Before:

Thu Sep 07 06:05:43 UTC 2023

After:

20230920-1314

Actions #4

Updated by Jim Pingle 7 months ago

  • Status changed from Feedback to New
Actions #5

Updated by Jim Pingle 7 months ago

We could have the widget parse that datestamp and output a more human-readable string. That's probably easier than altering the build process to output the time differently.

Actions #6

Updated by Jim Pingle 7 months ago

  • Assignee changed from Brad Davis to Jim Pingle
Actions #7

Updated by Jim Pingle 7 months ago

  • Status changed from New to Feedback
Actions #8

Updated by Jim Pingle 7 months ago

  • Status changed from Feedback to Resolved

New code appears to be working properly

Actions #9

Updated by Jim Pingle 5 months ago

  • Target version changed from 2.8.0 to 2.7.1
Actions

Also available in: Atom PDF