Project

General

Profile

Actions

Bug #15035

closed

System GUI unaccessable

Added by Jonathan Lee 3 months ago. Updated 3 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Unknown
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Release Notes:
Default
Affected Plus Version:
23.05.1
Affected Architecture:
SG-2100

Description

/head.inc, Line: 535, Message: Uncaught TypeError: count): Argument #1 (Svalue) must be of type Countable|array, bool given in /usr/local/www/head.inc:535 Stack trace: #0 /usr/local/www/index.php(309): include() #1 {main} thrown

My system has be depreciated


Files

Screenshot 2023-11-26 at 5.48.00 PM.png (176 KB) Screenshot 2023-11-26 at 5.48.00 PM.png Jonathan Lee, 11/27/2023 02:00 AM
Screenshot 2023-11-26 at 6.23.52 PM.png (174 KB) Screenshot 2023-11-26 at 6.23.52 PM.png Jonathan Lee, 11/27/2023 02:25 AM
Screenshot 2023-11-26 at 6.27.33 PM.png (623 KB) Screenshot 2023-11-26 at 6.27.33 PM.png Jonathan Lee, 11/27/2023 02:27 AM
Screenshot 2023-11-27 at 8.23.33 AM.png (184 KB) Screenshot 2023-11-27 at 8.23.33 AM.png Interface to Interface blocking Jonathan Lee, 11/27/2023 04:27 PM
Screenshot 2023-11-27 at 8.23.52 AM.png (558 KB) Screenshot 2023-11-27 at 8.23.52 AM.png Layer 2 Rules blocking interface to interface pcmie card compex Jonathan Lee, 11/27/2023 04:27 PM
Screenshot 2023-11-27 at 8.23.59 AM.png (535 KB) Screenshot 2023-11-27 at 8.23.59 AM.png ACL on other interface non guest wifi External AP Side Jonathan Lee, 11/27/2023 04:27 PM
Screenshot 2023-11-27 at 8.24.08 AM.png (226 KB) Screenshot 2023-11-27 at 8.24.08 AM.png Snort running with AppID enabled 23.05.01 stable Jonathan Lee, 11/27/2023 04:27 PM
Screenshot 2023-11-27 at 8.24.29 AM.png (420 KB) Screenshot 2023-11-27 at 8.24.29 AM.png Snort showing AppID blocks Jonathan Lee, 11/27/2023 04:28 PM
Screenshot 2023-11-27 at 8.25.07 AM.png (504 KB) Screenshot 2023-11-27 at 8.25.07 AM.png Custom AppID text rules being used Jonathan Lee, 11/27/2023 04:28 PM
custom.rtf (289 KB) custom.rtf my AppID text rules I use Jonathan Lee, 11/27/2023 04:28 PM
Screenshot 2023-11-27 at 8.31.51 AM.png (197 KB) Screenshot 2023-11-27 at 8.31.51 AM.png WiFi working for Guest Side Jonathan Lee, 11/27/2023 04:32 PM
Screenshot 2023-11-27 at 8.32.58 AM.png (373 KB) Screenshot 2023-11-27 at 8.32.58 AM.png Squid Custom Config Jonathan Lee, 11/27/2023 04:33 PM
Screenshot 2023-11-27 at 8.33.33 AM.png (618 KB) Screenshot 2023-11-27 at 8.33.33 AM.png Squid running Jonathan Lee, 11/27/2023 04:33 PM
Screenshot 2023-11-27 at 8.34.11 AM.png (210 KB) Screenshot 2023-11-27 at 8.34.11 AM.png WPAD in use Jonathan Lee, 11/27/2023 04:35 PM
Screenshot 2023-11-27 at 8.35.17 AM.png (255 KB) Screenshot 2023-11-27 at 8.35.17 AM.png DNS over TLS in use Jonathan Lee, 11/27/2023 04:35 PM
Screenshot 2023-11-27 at 8.36.06 AM.png (474 KB) Screenshot 2023-11-27 at 8.36.06 AM.png DHCP options AP external 192. subnet Jonathan Lee, 11/27/2023 04:36 PM
Screenshot 2023-11-27 at 8.36.39 AM.png (414 KB) Screenshot 2023-11-27 at 8.36.39 AM.png DHCP options internal card different subnet 10. Jonathan Lee, 11/27/2023 04:37 PM
Screenshot 2023-11-27 at 8.36.45 AM.png (352 KB) Screenshot 2023-11-27 at 8.36.45 AM.png DHCP options internal custom Jonathan Lee, 11/27/2023 04:37 PM
Screenshot 2023-11-27 at 8.38.11 AM.png (246 KB) Screenshot 2023-11-27 at 8.38.11 AM.png Authenticated NTP in use Jonathan Lee, 11/27/2023 04:38 PM
Screenshot 2023-11-27 at 8.39.04 AM.png (397 KB) Screenshot 2023-11-27 at 8.39.04 AM.png Snort Path to Splice File Jonathan Lee, 11/27/2023 04:39 PM
custom.rtf (3.14 KB) custom.rtf Splice File contents Jonathan Lee, 11/27/2023 04:39 PM
Screenshot 2023-11-27 at 8.40.10 AM.png (545 KB) Screenshot 2023-11-27 at 8.40.10 AM.png ISP has no ipv6 disabled Jonathan Lee, 11/27/2023 04:40 PM
Screenshot 2023-11-27 at 8.41.02 AM.png (475 KB) Screenshot 2023-11-27 at 8.41.02 AM.png Squidguard in use Jonathan Lee, 11/27/2023 04:41 PM
Screenshot 2023-11-27 at 8.41.10 AM.png (630 KB) Screenshot 2023-11-27 at 8.41.10 AM.png Squidguard running Jonathan Lee, 11/27/2023 04:41 PM
Screenshot 2023-11-27 at 8.42.18 AM.png (497 KB) Screenshot 2023-11-27 at 8.42.18 AM.png Cron jobs for custom led Jonathan Lee, 11/27/2023 04:42 PM
Screenshot 2023-11-27 at 8.43.28 AM.png (237 KB) Screenshot 2023-11-27 at 8.43.28 AM.png led day Jonathan Lee, 11/27/2023 04:43 PM
led.rtf (1.9 KB) led.rtf online led cron Jonathan Lee, 11/27/2023 04:44 PM
Screenshot 2023-11-27 at 8.45.00 AM.png (392 KB) Screenshot 2023-11-27 at 8.45.00 AM.png led night alarm cron Jonathan Lee, 11/27/2023 04:45 PM
Screenshot 2023-11-27 at 8.45.42 AM.png (436 KB) Screenshot 2023-11-27 at 8.45.42 AM.png upnp Jonathan Lee, 11/27/2023 04:46 PM
Screenshot 2023-11-27 at 8.46.19 AM.png (354 KB) Screenshot 2023-11-27 at 8.46.19 AM.png static nat Jonathan Lee, 11/27/2023 04:46 PM
Screenshot 2023-11-27 at 8.47.09 AM.png (490 KB) Screenshot 2023-11-27 at 8.47.09 AM.png only way wifi worked on card Jonathan Lee, 11/27/2023 04:47 PM
Screenshot 2023-11-27 at 8.48.12 AM.png (426 KB) Screenshot 2023-11-27 at 8.48.12 AM.png backups Jonathan Lee, 11/27/2023 04:48 PM
Screenshot 2023-11-27 at 8.48.44 AM.png (429 KB) Screenshot 2023-11-27 at 8.48.44 AM.png boot enviroments Jonathan Lee, 11/27/2023 04:49 PM
Screenshot 2023-11-27 at 8.49.26 AM.png (587 KB) Screenshot 2023-11-27 at 8.49.26 AM.png patches Jonathan Lee, 11/27/2023 04:49 PM
Screenshot 2023-11-27 at 8.52.07 AM.png (583 KB) Screenshot 2023-11-27 at 8.52.07 AM.png Jonathan Lee, 11/27/2023 04:52 PM
Screenshot 2023-11-27 at 8.53.30 AM.png (487 KB) Screenshot 2023-11-27 at 8.53.30 AM.png do not cache Jonathan Lee, 11/27/2023 04:54 PM
donotcache.rtf (1.77 KB) donotcache.rtf squid do not cache file Jonathan Lee, 11/27/2023 04:54 PM
Screenshot 2023-11-27 at 8.55.00 AM.png (524 KB) Screenshot 2023-11-27 at 8.55.00 AM.png squid does not use guest wifi interface Jonathan Lee, 11/27/2023 04:55 PM
Screenshot 2023-11-27 at 8.54.54 AM.png (365 KB) Screenshot 2023-11-27 at 8.54.54 AM.png subnet blocked guest wifi Jonathan Lee, 11/27/2023 04:55 PM
Screenshot 2023-11-27 at 8.56.09 AM.png (274 KB) Screenshot 2023-11-27 at 8.56.09 AM.png port forwards Jonathan Lee, 11/27/2023 04:56 PM
Screenshot 2023-11-27 at 8.57.15 AM.png (243 KB) Screenshot 2023-11-27 at 8.57.15 AM.png traffic shaper in use DSL 6meg cop line Jonathan Lee, 11/27/2023 04:57 PM
Screenshot 2023-11-27 at 8.58.44 AM.png (224 KB) Screenshot 2023-11-27 at 8.58.44 AM.png shaper running limiter Jonathan Lee, 11/27/2023 04:59 PM
Screenshot 2023-11-27 at 8.59.38 AM.png (611 KB) Screenshot 2023-11-27 at 8.59.38 AM.png ACL secure side ex AP Lan Jonathan Lee, 11/27/2023 05:00 PM
Screenshot 2023-11-27 at 9.00.42 AM.png (232 KB) Screenshot 2023-11-27 at 9.00.42 AM.png ACL WAN inbound Jonathan Lee, 11/27/2023 05:01 PM
Screenshot 2023-11-27 at 9.00.15 AM.png (222 KB) Screenshot 2023-11-27 at 9.00.15 AM.png ACL guest wifi Jonathan Lee, 11/27/2023 05:01 PM
Screenshot 2023-11-27 at 9.01.54 AM.png (614 KB) Screenshot 2023-11-27 at 9.01.54 AM.png ACL layer 2 Jonathan Lee, 11/27/2023 05:02 PM
Screenshot 2023-11-27 at 9.03.08 AM.png (441 KB) Screenshot 2023-11-27 at 9.03.08 AM.png Packages Jonathan Lee, 11/27/2023 05:03 PM
Screenshot 2023-11-27 at 9.04.52 AM.png (392 KB) Screenshot 2023-11-27 at 9.04.52 AM.png Avg memory use 23-30% Jonathan Lee, 11/27/2023 05:05 PM
Screenshot 2023-11-27 at 9.07.02 AM.png (3.34 MB) Screenshot 2023-11-27 at 9.07.02 AM.png GUI art used Jana Matejki Jonathan Lee, 11/27/2023 05:07 PM
Screenshot 2023-11-27 at 9.10.05 AM.png (553 KB) Screenshot 2023-11-27 at 9.10.05 AM.png ARM so rules do not work on ARM processor Jonathan Lee, 11/27/2023 05:10 PM
Screenshot 2023-11-27 at 9.10.58 AM.png (510 KB) Screenshot 2023-11-27 at 9.10.58 AM.png Squid Lite Runs Jonathan Lee, 11/27/2023 05:11 PM
Actions #1

Updated by Jonathan Lee 3 months ago

I noticed this after some snort changes when this GUI access was removed

Changes marked unknown...

Actions #3

Updated by Jim Pingle 3 months ago

  • Status changed from New to Rejected
  • Priority changed from High to Normal

There is no code like that on line 535 in a current version of head.inc. On 23.05.1 it would imply that the content of the notices variable isn't an array somehow, but we can't accept problem reports from past releases, only current versions.

Unless you or someone else can replicate that bug on 23.09 or 24.03 snapshots somehow then we can only assume it's already been fixed. If it can be replicated we need to know the exact steps taken to replicate the issue.

Actions #4

Updated by Jonathan Lee 3 months ago

Steps to reproduce.

1. Use boot environments I went to test out 23.09 again with the latest Snort update. I started that environment and installed my latest config file. Once packages installed and Snort activated I lost access to the GUI menu. I rebooted and disabled Snort blocking and it worked.

2. Go back to the stable version 23.05.01 the version where snort works with the old .12 snort without core dumps.

3. Attempted to change a rule from wifi interface pcie card to block guest WiFi to secure side interference from address to subnet.

4. Safe and go back to snort check blocks restarted snort on WAN.

5. Log out

6. I logged in and lost GUI it would not log in anymore for 23.05.01.

7. Restore old config fix ACL rule and GUI restored for stable version 23.05.01 with Snort .12

Actions #5

Updated by Jonathan Lee 3 months ago

23.09 is not stable for Snort it just doesn't work with it on ARM.

Actions #10

Updated by Jonathan Lee 3 months ago

took from 2019 until 23.05.01 for this to be stable

23.09 on arm processor is not stable with Snort active .14 version

Actions #11

Updated by Jim Pingle 3 months ago

None of that is relevant if you cannot reproduce the PHP error while you are on a stock/unmodified 23.09. If you only see the PHP error on 23.05.1 then it's probably already been fixed.

Actions #12

Updated by Jonathan Lee 3 months ago

Squid uses both splice for some and intercept for others

Actions #16

Updated by Jonathan Lee 3 months ago

Packages running

23.05.01 final ARM SG2100 stable version time to stable config 2019->2023

I hope that provides background if ever needed. Snort also uses paid subscription rule set non-free

Actions #17

Updated by Jonathan Lee 3 months ago

23.09 is not stable when Snort is used with blocking enabled it will depreciate a firewall to no gui access with blocking kill states enabled.

Actions #18

Updated by Jonathan Lee 3 months ago

Thank you open source community for all you do.

Actions #20

Updated by Jonathan Lee 3 months ago

I had to uninstall Snort to access the web GUI. It does not work for my configuration you see above at all. I am stuck with 23.05.01 that's ok that is the most stable version I have ever had on the SG2100. I think that is where my system will die at. I can not get past the SNORT issues, they are so bad it blocks me from even accessing the GUI. I accessed it with console I was able to remove SNORT package and it has GUI access again. However many devices will no longer connect to the firewall with the 23.09 version. Thanks for looking into this I suspect this is an ARM processor issue for SNORT. I can no longer move past 23.05.01 that is it for me. I posted this to showcase how good it was and how the new version no longer is functional at all.

Actions #21

Updated by Jonathan Lee 3 months ago

NogBadTheBad
also stated issues with the ".14 fix" Snort update however the thread was locked right after he reported it. I also state it is not fixed

Actions #23

Updated by Jonathan Lee 3 months ago

TAC ticket number is: 2113707645

Actions #24

Updated by Jonathan Lee 3 months ago

23.05.01 with squid was the everything bagel of open source community firewall software... 🥯

Actions

Also available in: Atom PDF