Project

General

Profile

Actions

Feature #15375

closed

Update ntopng package

Added by Denny Page 3 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
ntop
Target version:
-
Start date:
Due date:
% Done:

100%

Estimated time:
Plus Target Version:

Description

This is a tracking issue for a significant number of changes to pfSense-pkg-ntopng.

The list of changes to the package is as follows:

  • Update for PHP 8.
  • Support newly required Account ID for MaxMind GeoLite2 downloads.
  • Run ntopng without root privileges.
  • Add option to disable setting promiscuous mode on monitored interfaces.
  • Allow selection of a specific interface for the ntopng server to listen on.
  • Add support for the ntopng server listening on IPv6 addresses.
  • Move ntopng configuration options from the command line into a configuration file. This allows for credentials, such as those required by dump-flows, to be secured.
  • Support the addition of configuration lines outside those directly supported by the pfSense ntop package UI. This allows for customization beyond the capabilities of the package, such as importing or exporting flows to another ntopng instance.
  • Use the demonize capability of the redis server.
  • Record in redis that the admin password has already been set. Without this, ntopng forces the change of the admin password on first access.
  • Provide an option to delete ntopng data (traffic and alerts) without destroying the ntopng configuration (preferences and customizations).
  • Clarify the use of the local networks setting, and remove unnecessary options. Selected/monitored networks are already considered as local by ntopng. The --local-networks option is only used for adding networks that are not already known.
  • Support setting names for additional local networks.

A PR will be available shortly.

Actions #1

Updated by Mike Moore 3 months ago

"Support the addition of configuration lines outside those directly supported by the pfSense ntop package UI. This allows for customization beyond the capabilities of the package, such as importing or exporting flows to another ntopng instance."

Will there be a way to add license key information to take advantage of features in the paid version?

Actions #2

Updated by Denny Page 3 months ago

Mike Moore wrote in #note-1:

"Support the addition of configuration lines outside those directly supported by the pfSense ntop package UI. This allows for customization beyond the capabilities of the package, such as importing or exporting flows to another ntopng instance."

Will there be a way to add license key information to take advantage of features in the paid version?

This is an update to the pfSense ntopng package (pfSense-pkg-ntopng-5.6.0.pkg), which controls the run-time configuration for ntopng. It is not ntopng itself.

The underlying ntopng package (ntopng-5.6.d20230531_1,1.pkg), which contains the actual ntopng executable, comes from FreeBSD ports. This version is the community edition built from Github source, and does not support the addition of licenses.

FWIW, ntop provides instructions for installing the commercial version of ntopng on pfSense if you so desire. You can find them here: https://www.ntop.org/guides/ntopng/third_party_integrations/pfsense.html#pfsenseintegration
The page includes instructions on where to place the license file if you have one.

Actions #3

Updated by Mike Moore 3 months ago

Understood. Thank you Denny.

Actions #4

Updated by Jim Pingle 3 months ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

PR merged, thanks!

Actions #5

Updated by Denny Page 3 months ago

The package has been tested by a couple of users on 23.09.1, and it works as intended.

Actions #6

Updated by Denny Page 3 months ago

Tested in 24.03 RC -- working as intended.

Actions #7

Updated by Denny Page 2 months ago

This can be closed as complete. Thanks.

Actions #8

Updated by Jim Pingle 2 months ago

  • Status changed from Feedback to Resolved
Actions

Also available in: Atom PDF