Project

General

Profile

Actions

Feature #1726

closed

Allow disabling the "Autonomous address-configuration"

Added by Chris Buechler over 10 years ago. Updated over 10 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
07/29/2011
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:

Description

You should add a checkbox allowing to disable the "Autonomous address-configuration", setting the rtadvd option "pinfoflags" to 0 (or "") for the interface.

In my case, i need to disable this to keep the router advertisement but not to have autoconfigurated addresses or subnets delivered (because i have several different subnets linked to the same interface)

Actions #1

Updated by Seth Mos over 10 years ago

My thought was to add this as a choice from the drop down on the DHCP server page.

The config code currently does not take this flag into consideration which it really should.

Would a "Advertise router Only" in the dropdown do the trick? Unmanaged being autoconfig. Assisted is both and managed is DHCP6 only.

Actions #2

Updated by Seth Mos over 10 years ago

  • Status changed from New to Feedback

Added a "router" type that sends pinfoflags as being "". From the confusing documentation this might need to be "l" which is link but not autoconfig.

Needs testing.

Actions #3

Updated by Seth Mos over 10 years ago

  • Status changed from Feedback to Resolved

Confirmed that my Macbook with 10.5 only has a link-local address when set to router-only. you can Still enable DHCP6 ofcourse. Some clients will start a client regardless from the bits set in the advertisement.

pfSense does this too, and it officially breaks the RFC that it should only start when the router advertisemnt says so. I can't care enough.

Actions

Also available in: Atom PDF