Project

General

Profile

Bug #198

Web interface garbage

Added by Thierry Pimont over 9 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Web Interface
Target version:
Start date:
11/30/2009
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

Hello i try a fresh install from livecd to solve some bugs iso pfSense-2.0-ALPHA-ALPHA-20091129-0034.iso.gz,pfSense-2.0-ALPHA-ALPHA-20091129-0409.iso.gz and pfSense-2.0-ALPHA-ALPHA-20091130-0058.iso.gz.

When i try to connect to web interface i got garbage characters

0dhuy.png (99.4 KB) 0dhuy.png garbage interface Thierry Pimont, 11/30/2009 10:59 AM

Associated revisions

Revision 9444761e (diff)
Added by Scott Ullrich over 9 years ago

Turn off compression for time being. Ticket #198

Revision 570ef08c (diff)
Added by Scott Ullrich over 9 years ago

Use lighty compression instead of php gzip Resolves #198

Revision 4682fb7d (diff)
Added by Scott Ullrich over 8 years ago

Turn zlib compression back on. Tested by and reminded by Pierre Pomes. Ticket #198 ... Apparently lighttpd was not compressing the php pages so this should be turned back on according to Pierre Pomes (and tested by him).

Revision 9e38e8bd (diff)
Added by Sjon Hortensius about 4 years ago

fix indenting, remove htmlspecialchars refs #198

History

#1 Updated by Pierre POMES over 9 years ago

I also had the same problem for an full upgrade to pfSense-Full-Update-2.0-ALPHA-ALPHA-20091130-0110.tgz.

This seems to be a "deflate/gzip issue": lightttpd returns a compressed content in the http response, without the appropriate header.

Temporary workaround: disable gzip and/or deflate encoding in your browser and the GUI will work again

#2 Updated by Thierry Pimont over 9 years ago

It's deflate/gzip issue.

the latest snapshot 01/12 is without gzip, so its ok.

thank you

#3 Updated by Seth Mos over 9 years ago

  • Status changed from New to Resolved

#4 Updated by Scott Ullrich over 9 years ago

  • Status changed from Resolved to New

While I would love to mark this is resolved unfortunately I just worked around the issue.

We still need to determine why the problem is happening so we can re-enable compression.

Pier mentioned that it might be better to do gzip at the lighttpd level which sounds good to me.

#5 Updated by Scott Ullrich over 9 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF