Project

General

Profile

Bug #202

Theme problems with IE 8

Added by Chris Buechler over 9 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Web Interface
Target version:
Start date:
12/01/2009
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

There are at least a couple problems with the default theme in 2.0 with IE 8, possibly limited to Windows 7 only, unknown for sure.

A couple have reported this:
http://forum.pfsense.org/index.php/topic,20218.msg107388.html#msg107388

I personally don't see that on Windows 7 64 bit, but when I click + on the Dashboard nothing happens.

Associated revisions

Revision 011b9493 (diff)
Added by Scott Ullrich over 9 years ago

Adding latest dom_TT. Fixes #202 Thanks to RobisCool

Revision ca4d3b80 (diff)
Added by Sjon Hortensius about 4 years ago

proper indenting; reveals redundant </div>. Warning; gettext madness..

refs #202

History

#1 Updated by Jim Pingle over 9 years ago

Using IE8 on Win7 in normal mode, I see the menu but the RSS widget causes rendering issues. The "+" does nothing on the Dashboard.

If I turn on compatibility mode, the menu is blank but the widgets render fine and the "+" works.

#2 Updated by Scott Ullrich over 9 years ago

  • Status changed from New to Feedback

#3 Updated by Scott Ullrich over 9 years ago

  • Status changed from Feedback to New

#4 Updated by Holger Bauer over 9 years ago

So the menuissue only affects compatibilitymode in IE8? Compatibilitymode mimics IE6 and IE6 was broken by design. It doesn't support all the CSS (especially transparency effects) that this theme is using. We rather should fix the Dashboard to run in noncompatibility mode than trying to fix what's not fixable (IE6) for this theme.

#5 Updated by Scott Ullrich over 9 years ago

How would we change the dashboard to run in non compatibility mode?

#6 Updated by robert zelaya over 9 years ago

Using the theme "the wall", the main top menu is broken in IE8 compability mode.

#7 Updated by Scott Ullrich over 9 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF