Project

General

Profile

Actions

Feature #2071

closed

Allow link local addresses for gateways

Added by Seth Mos almost 10 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Routing
Target version:
Start date:
01/05/2012
Due date:
% Done:

0%

Estimated time:
1.00 h
Plus Target Version:
Release Notes:

Description

In the IPv6 world it is completely valid to use link local addresses for gateways. We currently do not allow those.

We already added some link local support for dhcp6 as we pick up the link local default from the route table.

We need to make sure we add the route into the route table with the interface scope added. e.g. fe80::1%igb3

Actions #1

Updated by Seth Mos almost 10 years ago

  • Status changed from New to Feedback

OK, I've added support for allowing link local addresses in the gateways form.

I've also added link local address output on the status_interfaces.php because just plain using ifconfig on the command page is less then intuitive to find it.

Actions #2

Updated by Seth Mos over 9 years ago

Confirmed working

Actions #3

Updated by Seth Mos over 9 years ago

  • Status changed from Feedback to Resolved
Actions #4

Updated by Chris Buechler over 9 years ago

  • Target version changed from 8 to 2.1
Actions

Also available in: Atom PDF