Project

General

Profile

Actions

Bug #2330

closed

vouchers disappear when saving

Added by Chris Buechler over 9 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Captive Portal
Target version:
Start date:
03/31/2012
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.1
Affected Architecture:

Description

config attached to replicate.

Browse to Services>CP, edit the zone, go to the Vouchers tab. You'll see the vouchers there at the top. Hit Save at the bottom and they're completely gone from the config.


Files

Actions #1

Updated by Darren Embry over 9 years ago

  • Status changed from Assigned to Feedback
  • % Done changed from 0 to 20

I've troubleshooted and confirmed that in this scenario, lines 229-244 here are being executed when you click "Save"; line 242 here in particular is to blame for erasing voucher config info:
https://github.com/bsdperimeter/pfsense/blob/8b320242759a783ebecd28dcbd57c1262844cbc4/usr/local/www/services_captiveportal_vouchers.php

I have reason to believe that those lines are not intended to be executed when you have an existing voucher config and click "Save", as is the case in this scenario. Perhaps someone can shed some light on what circumstances those lines of code are supposed to be called under?

Actions #2

Updated by Ermal Luçi over 9 years ago

  • % Done changed from 20 to 100
Actions #3

Updated by Darren Embry over 9 years ago

Has this issue been resolved? You can answer by marking it as such. Thanks. :-)

Actions #4

Updated by Chris Buechler over 9 years ago

  • Status changed from Feedback to Resolved

fixed

Actions

Also available in: Atom PDF