Project

General

Profile

Actions

Bug #238

closed

Add new gateway on interfaces.php doesn't work on OPT interfaces

Added by Chris Buechler almost 12 years ago. Updated almost 12 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
12/21/2009
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.0
Affected Architecture:

Description

It looks like it works, i.e. after adding a gateway it's shown in the gateways drop down, but the gateway isn't actually added and if you save with that new gateway selected it kicks back with invalid gateway.

Actions #1

Updated by Seth Mos almost 12 years ago

What I think might be happening is that the input validation throws a error and thus doesn't save.
Not sure entirely but maybe it does output the new name because javascript blindly sets the name from the popup.

Actions #2

Updated by Scott Ullrich almost 12 years ago

  • Status changed from New to Feedback

Just tested a fresh install and could not reproduce this. Steps taken, install, interfaces wan, set to static, entered 10.0.250.240/24. Clicked create new gateway ajax widget and typed in 10.0.250.1 and a description. It created and then I applied with no errors.

Actions #3

Updated by Chris Buechler almost 12 years ago

  • Subject changed from Add new gateway on interfaces.php doesn't work to Add new gateway on interfaces.php doesn't work on OPT interfaces
  • Status changed from Feedback to New

Confirmed it does work on WAN, it doesn't work on any OPT interfaces. Does as described in the description.

Actions #4

Updated by Scott Ullrich almost 12 years ago

  • Status changed from New to Feedback

Fixed in r5c31099

Actions #5

Updated by Chris Buechler almost 12 years ago

  • Status changed from Feedback to Resolved

fixed

Actions

Also available in: Atom PDF