Project

General

Profile

Actions

Bug #2458

closed

Pfsense not registering DNS servers found by PPP

Added by royden yates over 9 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
PPP Interfaces
Target version:
Start date:
05/28/2012
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.1
Affected Architecture:

Description

2.1-DEVELOPMENT (i386) - built May 27 05:31:49 EDT 2012 on i386

If system general DNS settings are left empty no dns servers are picked up and used over PPP even though PPP log shows that dns entries are transmitted. All is well with manual entry of dns servers under System: General Setup.

Forum link: [[http://forum.pfsense.org/index.php/topic,49565.0.html]]


Files

PPP_log_fail.txt (8.42 KB) PPP_log_fail.txt royden yates, 05/28/2012 03:32 PM
mpd_wan.conf (1.09 KB) mpd_wan.conf royden yates, 05/28/2012 08:34 PM
Actions #1

Updated by Seth Mos over 9 years ago

  • Status changed from New to Feedback

I committed a fixed ppp-linkup script. It looks like what used to be 2 different variables is now a single variable.

Works for my 3G modem, so I'd guess it works for PPPoE too. Might need MFC to RELENG_2_0

Actions #2

Updated by royden yates over 9 years ago

My modem is a Huawei LTE e398

The modified ppp-linkup script fails for me and results in the modem being unresponsive. Tried variously, with reboots no difference. Copying back the old script and manually entering dns info restores connection, after re-enabling interface.

Attached is the PPP log.

Shout for more if needed.

Actions #3

Updated by royden yates over 9 years ago

My comment may be invalid as I have a different response from snap 2.1-DEVELOPMENT (i386)
built on Mon May 28 10:16:21 EDT 2012 that includes the relevant commit than I did from testing only ppp-linkup. Still does not work however, and needs manual dns info.

Actions #4

Updated by royden yates over 9 years ago

Using snap built on Mon May 28 10:16:21 EDT 2012 I cannot reproduce the log from using the ppp-linkup (Revision 703173f2) copied over to snap built May 27 05:31:49 EDT 2012 on i386. For one, the PPP-log now contains no comms between the modem and the AP yet the system registers an IP and gateway and the interface is up but lacks dns entries (which can be manually entered with success). Both tests thus have same outcome but different logs.

Note: in snap Mon May 28 10:16:21 EDT 2012 if the interface is disconnected and then reconnected this results in a hung modem and needs a reboot. PPP log shows endless re-connection attempts:

"May 29 01:28:19 ppp: [wan_link0] Link: reconnection attempt 1 in 4 seconds
May 29 01:28:23 ppp: [wan_link0] Link: reconnection attempt 1
May 29 01:28:36 ppp: [wan_link0] CHAT: The modem is not responding to "AT" at ModemCmd: label.
May 29 01:28:36 ppp: [wan_link0] MODEM: chat script failed
May 29 01:28:36 ppp: [wan_link0] Link: DOWN event
May 29 01:28:36 ppp: [wan_link0] LCP: Down event"

This "hang" does not happen if ppp-linkup prior to Revision 703173f2 is copied to snap Mon May 28 10:16:21 EDT 2012. Interface can be taken down and then up.

Have attached /var/etc/mpd_wan.conf

Actions #5

Updated by Vladimir Putin over 9 years ago

2.1-BETA0 (i386)
built on Wed May 30 19:35:31 EDT 2012
FreeBSD 8.3-RELEASE-p2

The script IS NOT working for me also. (direct PPPoE connection without any modems between)

Actions #6

Updated by Vladimir Putin over 9 years ago

ThorstenK code, posted in forum, works flawlessly for me (I use IPv4 only)

Actions #7

Updated by Chris Buechler over 9 years ago

  • Status changed from Feedback to New
  • Target version set to 2.1
Actions #8

Updated by Seth Mos over 9 years ago

  • Status changed from New to Feedback

Ok, replaced cut with awk and now it does what I intended, fixed on PPPoE test and PPP 3G test. (v4 only)

Actions #9

Updated by Vladimir Putin over 9 years ago

Works for me too now, thanks a lot.

Actions #10

Updated by Chris Buechler over 9 years ago

  • Status changed from Feedback to Resolved
Actions

Also available in: Atom PDF